summaryrefslogtreecommitdiff
path: root/dev-perl/Filesys-Notify-Simple
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Filesys-Notify-Simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Filesys-Notify-Simple')
-rw-r--r--dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.100.0.ebuild25
-rw-r--r--dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.120.0.ebuild25
-rw-r--r--dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.80.0.ebuild20
-rw-r--r--dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.90.0.ebuild25
-rw-r--r--dev-perl/Filesys-Notify-Simple/Manifest4
-rw-r--r--dev-perl/Filesys-Notify-Simple/metadata.xml9
6 files changed, 108 insertions, 0 deletions
diff --git a/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.100.0.ebuild b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.100.0.ebuild
new file mode 100644
index 00000000000..798c57e51e3
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.100.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.10
+inherit perl-module
+
+DESCRIPTION="Simple and dumb file system watcher"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Filter"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-SharedFork
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.120.0.ebuild b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.120.0.ebuild
new file mode 100644
index 00000000000..ceddd6e30df
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.120.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.12
+inherit perl-module
+
+DESCRIPTION="Simple and dumb file system watcher"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Filter"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-SharedFork
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.80.0.ebuild b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.80.0.ebuild
new file mode 100644
index 00000000000..2ddab24ad13
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.80.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Simple and dumb file system watcher"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Filter"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
diff --git a/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.90.0.ebuild b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.90.0.ebuild
new file mode 100644
index 00000000000..a1c86b32394
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/Filesys-Notify-Simple-0.90.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION="Simple and dumb file system watcher"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Filter"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-SharedFork
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Filesys-Notify-Simple/Manifest b/dev-perl/Filesys-Notify-Simple/Manifest
new file mode 100644
index 00000000000..4a6bf56cad2
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/Manifest
@@ -0,0 +1,4 @@
+DIST Filesys-Notify-Simple-0.08.tar.gz 48916 SHA256 f1756b682c38dea39ee382273f2b651136b9d640e8c0f07c85733914b7a75310 SHA512 fecdc3c6388ad50e4cdddb4c1a74a57089956559442c6c67ee72eb9c106336973b6f34803c0d8a52086db2e2deeb7b9d2f06a42736f66f2cbe1a83ac2166a5b6 WHIRLPOOL 9e8ff71b44aac02fe59e4835c9262c00aad90834a7e4a30eee07048ec50d5863fc13f0a2e281a5ec5354c0fd30cbbb4dcab7e6a858bad4c31c645ac3e6e28a58
+DIST Filesys-Notify-Simple-0.09.tar.gz 24047 SHA256 83cfe03fdc6ce527d421479005bb9b5fda383489b284774f5928a054237c58be SHA512 53d451faf93ec59e14d3df828e3e6471b06d99be4e5c3e9304d3db64f259698a90ba0530fe7877cf45d56d3e9e478f8d83590a6b9f016a8d82db73321a971d95 WHIRLPOOL 539c49c0d0c9834bb59a949d42919cb19abf27e30afb933aa6fb8b97096751507733728ebeb78589786c45f6cfb07382827caa865c97354d3da1f2c8f5c2d075
+DIST Filesys-Notify-Simple-0.10.tar.gz 24191 SHA256 b526ab0ceff0286a85f1fefb8be9e99c417971f710eb2f8fa3aad33e6028932b SHA512 ad09ee3b9c29466bfdbc66c61002df2003b34d2defdce67c796fe4a1c176d6c3bf59dc0e5c6f29b191e730c76fa64db06251b86de56e5272b0a0db9c4f324c10 WHIRLPOOL 0e74cbb083f0601af0dec00e739cedc10cc5f830f18a9fd3a7c43b7cd113ee8419b60bf388a37b7f02efaaa607ff97df7db8f8b08676dfa7ffd76df80499e87b
+DIST Filesys-Notify-Simple-0.12.tar.gz 12935 SHA256 ecafcdfdebd0706fdf1bb7ee1bbbc304a65d70c6cc05255d14fd133da6aca60d SHA512 3edb9a5087b82c87bea1b4092a3c7c264ec6f8da391052593e504b16392ea1a84771bbcbad21d623f727682cc6ab4474fe6a7e346c8bebe13f60d39e83594e2b WHIRLPOOL 4bd5cb5ec84c503e3f80e5937f212179fa02aac63555b5789835ae9b116689d58c0e522801d5b8968c5b2926cc764c37a66b968662d7d4020e65e36cd30f92ae
diff --git a/dev-perl/Filesys-Notify-Simple/metadata.xml b/dev-perl/Filesys-Notify-Simple/metadata.xml
new file mode 100644
index 00000000000..1e606e07087
--- /dev/null
+++ b/dev-perl/Filesys-Notify-Simple/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Filesys-Notify-Simple</remote-id>
+ <remote-id type="cpan-module">Filesys::Notify::Simple</remote-id>
+ </upstream>
+</pkgmetadata>