summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-TableContentParser
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/HTML-TableContentParser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/HTML-TableContentParser')
-rw-r--r--dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild21
-rw-r--r--dev-perl/HTML-TableContentParser/Manifest1
-rw-r--r--dev-perl/HTML-TableContentParser/files/0.13-test.patch74
-rw-r--r--dev-perl/HTML-TableContentParser/metadata.xml14
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild b/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild
new file mode 100644
index 00000000000..61807348df1
--- /dev/null
+++ b/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SDRABBLE
+MODULE_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Parse the content of tables in HTML"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="dev-perl/HTML-Parser"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+PATCHES=( "${FILESDIR}"/0.13-test.patch )
diff --git a/dev-perl/HTML-TableContentParser/Manifest b/dev-perl/HTML-TableContentParser/Manifest
new file mode 100644
index 00000000000..447f7fa3f83
--- /dev/null
+++ b/dev-perl/HTML-TableContentParser/Manifest
@@ -0,0 +1 @@
+DIST HTML-TableContentParser-0.13.tar.gz 4664 SHA256 3eb9c80f65adf508300a95f591d8c58dcb7d74e90b1b7e5d4d9908599c5b5568 SHA512 0707a0059a7d885052615ee7badecc8915d5f8c67fd8683a226e23a0690f1872519475c32f51f299333c3208c20ea15380624fd0ebd1dc0b11457febfb3db585 WHIRLPOOL 3a446787d8998ea38d971082b3b74a459a64f80ad71c64b0e89767bf9536380594e2a891d524fd075ec8dfd76b3a1bc0a845895c927d6cb86ec3558ba450ecab
diff --git a/dev-perl/HTML-TableContentParser/files/0.13-test.patch b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
new file mode 100644
index 00000000000..79916acc1e1
--- /dev/null
+++ b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
@@ -0,0 +1,74 @@
+--- t/1.t
++++ t/1.t
+@@ -2,6 +2,8 @@
+
+
+ use Test;
++use strict;
++use warnings;
+
+ BEGIN { plan tests => 34 }
+
+@@ -20,7 +22,7 @@
+
+ ## Test object creation
+
+-$obj = HTML::TableContentParser->new();
++my $obj = HTML::TableContentParser->new();
+ ok(defined $obj, 1, $@);
+
+
+@@ -29,14 +31,14 @@
+ ## the correct values to the callback.
+
+
+-$table_caption = 'This is a caption';
+-$table_content1 = 'This is table cell content 1';
+-$table_content2 = 'This is table cell content 2';
+-$table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
+-$table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
+-$header_text = 'Header text';
++my $table_caption = 'This is a caption';
++my $table_content1 = 'This is table cell content 1';
++my $table_content2 = 'This is table cell content 2';
++my $table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
++my $table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
++my $header_text = 'Header text';
+
+-$html = qq{
++my $html = qq{
+ <html>
+ <head>
+ </head>
+@@ -59,7 +61,7 @@
+
+
+ $HTML::TableContentParser::DEBUG = 0;
+-$tables = $obj->parse($html);
++my $tables = $obj->parse($html);
+ ok($tables->[0]->{caption}->{data}, $table_caption, $@);
+ ok($tables->[0]->{rows}->[0]->{cells}->[0]->{data}, $table_content1, $@);
+ ok($tables->[0]->{rows}->[1]->{cells}->[0]->{data}, $table_content2, $@);
+@@ -124,16 +126,17 @@
+ ok(@$tables, 2, @_);
+
+ ## and three headers for each table
+-for $t (0..$#{@$tables}) {
+- for (0..$#hdrs) {
+- ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
++for my $t (0..(@$tables-1)) {
++ for (0..2) {
++ # ok($t, $t);
++ ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
+ }
+ }
+
+
+ ## and three rows of three cells each, for each table.. (18 total).
+-for $t (0..$#{@$tables}) {
+- for $r (0..$#rows) {
++for my $t (0..1) {
++ for my $r (0..$#rows) {
+ for (0..2) {
+ ok($tables->[$t]->{rows}->[$r]->{cells}->[$_]->{data}, $rows[$r]->[$_], $@);
+ }
diff --git a/dev-perl/HTML-TableContentParser/metadata.xml b/dev-perl/HTML-TableContentParser/metadata.xml
new file mode 100644
index 00000000000..f1516fb8d4f
--- /dev/null
+++ b/dev-perl/HTML-TableContentParser/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">HTML-TableContentParser</remote-id>
+ <remote-id type="cpan-module">HTML::TableContentParser</remote-id>
+ </upstream>
+</pkgmetadata>