summaryrefslogtreecommitdiff
path: root/dev-perl/IPTables-libiptc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/IPTables-libiptc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/IPTables-libiptc')
-rw-r--r--dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild37
-rw-r--r--dev-perl/IPTables-libiptc/Manifest3
-rw-r--r--dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch24
-rw-r--r--dev-perl/IPTables-libiptc/metadata.xml13
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild b/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild
new file mode 100644
index 00000000000..762940f1668
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAWK
+MODULE_VERSION=0.52
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Perl extension for iptables libiptc library"
+SRC_URI="${SRC_URI}
+http://dev.gentoo.org/~pinkbyte/distfiles/${PN}/${P}-support-for-iptables-1.4.12.patch.bz2
+http://dev.gentoo.org/~pinkbyte/distfiles/${PN}/${P}-support-for-iptables-1.4.16.2.patch.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# package dependency on iptables is very fragile
+# see https://rt.cpan.org/Public/Bug/Display.html?id=70639
+RDEPEND="<net-firewall/iptables-1.4.18:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}/${P}-support-for-iptables-1.4.12.patch"
+ "${WORKDIR}/${P}-support-for-iptables-1.4.16.2.patch"
+ "${FILESDIR}/${P}-respect-cflags.patch"
+)
+
+# Most of tests needs root access, but they do not fail without it
+SRC_TEST="do"
+
+src_prepare() {
+ tc-export CC
+ perl-module_src_prepare
+}
diff --git a/dev-perl/IPTables-libiptc/Manifest b/dev-perl/IPTables-libiptc/Manifest
new file mode 100644
index 00000000000..1a22088ffb2
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/Manifest
@@ -0,0 +1,3 @@
+DIST IPTables-libiptc-0.52.tar.gz 126058 SHA256 aa06ca77118fd0f8e3c2c7975eaf643b68be677b8085d96b814c31eebb925aca SHA512 df13b852669a0fe5bffe7e7bdcd7f00f22ae1ee73c6f9dcd3f08db5012ed91d48b1dffde6c894fd7d771c4c03ae2195820d019f35b6b3a24b0a2563de9202468 WHIRLPOOL c6755e7c66f6efb6ecbfdf87db5e4b5f82eae5c0120caddab476d61d9058c50e69cf050217bac8d0c29794097ac9fd92394b80b8873178b200ebf4d0525fadee
+DIST IPTables-libiptc-0.520.0-support-for-iptables-1.4.12.patch.bz2 17788 SHA256 422b32467b07846b3ff610cafd3dca0721d474cc86547fc371512f0b6a3b3421 SHA512 7ff2368e3e91df69521ed69cfc5ba8941301d4a229cf9bebed6fa374b41512120cddc4adddfbf76ae6ec1a3aa6ca17ebcaadd08b1afe11509b265e54461f7fa8 WHIRLPOOL d7f59ab420f50c3cbf83640f4583e3294b41def55dbd95e14fda62c5bef00334f11b634d370fa1c47bf05558571b69dc94f5fca9348e30b8268bed4a4fe56523
+DIST IPTables-libiptc-0.520.0-support-for-iptables-1.4.16.2.patch.bz2 17022 SHA256 e7891e2d0977ed5068ad755aeb94e07e42f5ca06d5495dbc102d2e16cfbbde70 SHA512 a9a07820baf185354f30d597bad9c059d53d194f8a534038557a593bb99f73acb9006ab4f66ea9b777cd4980c273f750e44b58f8cb28bf6fad52893d588aa440 WHIRLPOOL d39f33a71832646ec964163523b43e8f94557121f0ab19dde6abc011e131d3c24eacc10475574132701f115f6a529dac28da0cc042447581e810ca1a500f8fb5
diff --git a/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
new file mode 100644
index 00000000000..9453e6623ad
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig 2013-07-10 19:31:29.355162000 +0400
++++ Makefile.PL 2013-07-10 19:32:28.497557436 +0400
+@@ -256,7 +256,7 @@
+ LDDLFLAGS => '-shared -L$(PREFIX)/lib',
+ ## LDDLFLAGS => '-shared $(LOCAL_LIB_IPTC) -L$(PREFIX)/lib',
+ LDFLAGS => '-L$(PREFIX)/lib',
+- DEFINE => '-g -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
++ DEFINE => '$(CFLAGS) -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
+ # e.g., '-DHAVE_SOMETHING'
+ INC => '-I/usr/local/include -I./include -I.',
+ # e.g., '-I. -I/usr/include/other'
+
+--- iptables/Makefile.orig 2013-07-10 19:37:00.298563274 +0400
++++ iptables/Makefile 2013-07-10 19:37:16.786563628 +0400
+@@ -46,8 +46,7 @@
+ endif
+ LDLIBS=-ldl $(EXTRALIBS)
+
+-COPT_FLAGS:=-O2
+-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL -g
++CFLAGS+=-Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL
+ #-g -DDEBUG #-pg # -DIPTC_DEBUG
+
+ DEFINES:=-DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)
diff --git a/dev-perl/IPTables-libiptc/metadata.xml b/dev-perl/IPTables-libiptc/metadata.xml
new file mode 100644
index 00000000000..cf1696c6fcb
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">IPTables-libiptc</remote-id>
+ <remote-id type="cpan-module">IPTables::libiptc</remote-id>
+ </upstream>
+</pkgmetadata>