summaryrefslogtreecommitdiff
path: root/dev-perl/Image-Scale/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Image-Scale/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Image-Scale/files')
-rw-r--r--dev-perl/Image-Scale/files/0.80.0-disable_autodetect.patch44
-rw-r--r--dev-perl/Image-Scale/files/libpng-1.5-memcpy.patch11
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/Image-Scale/files/0.80.0-disable_autodetect.patch b/dev-perl/Image-Scale/files/0.80.0-disable_autodetect.patch
new file mode 100644
index 00000000000..3611479a812
--- /dev/null
+++ b/dev-perl/Image-Scale/files/0.80.0-disable_autodetect.patch
@@ -0,0 +1,44 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,6 +13,7 @@
+
+ my ($help, $jpeg_inc, $jpeg_lib, $png_inc, $png_lib, $gif_inc, $gif_lib, $gif_lib_name);
+ my ($jpeg_static, $png_static, $gif_static);
++my ($disable_jpeg, $disable_png, $disable_gif);
+
+ my $DEFINES = '-O2';
+ $DEFINES .= ' -Wall' unless $^O =~ /sun|solaris/i;
+@@ -29,6 +30,9 @@
+
+ my $result = GetOptions(
+ "help|h" => \$help,
++ "disable-jpeg" => \$disable_jpeg,
++ "disable-png" => \$disable_png,
++ "disable-gif" => \$disable_gif,
+ "with-jpeg-includes=s" => \$jpeg_inc,
+ "with-jpeg-libs=s" => \$jpeg_lib,
+ "with-jpeg-static" => \$jpeg_static,
+@@ -75,6 +79,7 @@
+
+ # Look for libjpeg
+ for my $incdir ( $jpeg_inc, @check ) {
++ last if $disable_jpeg;
+ if ( $incdir && -e catfile($incdir, 'jpeglib.h') ) {
+ $JPEG = 1;
+ $jpeg_inc = $incdir;
+@@ -111,6 +116,7 @@
+
+ # Look for libpng
+ for my $incdir ( $png_inc, @check ) {
++ last if $disable_png;
+ if ( $incdir && -e catfile($incdir, 'png.h') ) {
+ $PNG = 1;
+ $png_inc = $incdir;
+@@ -144,6 +150,7 @@
+
+ # Look for libgif
+ for my $incdir ( $gif_inc, @check ) {
++ last if $disable_gif;
+ if ( $incdir && -e catfile($incdir, 'gif_lib.h') ) {
+ $GIF = 1;
+ $gif_inc = $incdir;
diff --git a/dev-perl/Image-Scale/files/libpng-1.5-memcpy.patch b/dev-perl/Image-Scale/files/libpng-1.5-memcpy.patch
new file mode 100644
index 00000000000..fa9ad60cbc4
--- /dev/null
+++ b/dev-perl/Image-Scale/files/libpng-1.5-memcpy.patch
@@ -0,0 +1,11 @@
+--- a/src/png.c
++++ b/src/png.c
+@@ -40,7 +40,7 @@
+ }
+ }
+
+- png_memcpy(data, buffer_ptr(im->buf), len);
++ memcpy(data, buffer_ptr(im->buf), len);
+ buffer_consume(im->buf, len);
+
+ goto ok;