summaryrefslogtreecommitdiff
path: root/dev-perl/List-MoreUtils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/List-MoreUtils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/List-MoreUtils')
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.330.0-r1.ebuild17
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.408.0.ebuild29
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.413.0.ebuild30
-rw-r--r--dev-perl/List-MoreUtils/Manifest3
-rw-r--r--dev-perl/List-MoreUtils/metadata.xml9
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.330.0-r1.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.330.0-r1.ebuild
new file mode 100644
index 00000000000..8c9a5ee9921
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.330.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=0.33
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+SRC_TEST="do"
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.408.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.408.0.ebuild
new file mode 100644
index 00000000000..2de5e3c5412
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.408.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=REHSACK
+MODULE_VERSION=0.408
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Exporter-Tiny-0.38.0
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-IPC-Cmd
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.413.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.413.0.ebuild
new file mode 100644
index 00000000000..d841601b4e1
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.413.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=REHSACK
+MODULE_VERSION=0.413
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Exporter-Tiny-0.38.0
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-Carp
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-IPC-Cmd
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/List-MoreUtils/Manifest b/dev-perl/List-MoreUtils/Manifest
new file mode 100644
index 00000000000..c45d8ac2040
--- /dev/null
+++ b/dev-perl/List-MoreUtils/Manifest
@@ -0,0 +1,3 @@
+DIST List-MoreUtils-0.33.tar.gz 38997 SHA256 315c0b444c22b7bf207ac3c7e651d102c84a2308bfafb7a7efe095a9219494ad SHA512 e758b995438c5c5322317aab3602e89b9f683c42d403a0ac97ccd8cc20d0db1a75caefc22f34ad088314867c0bdd9c2b8264e8f2f6a43eab1421aa8c482233b5 WHIRLPOOL afd68dc7bc5ce5be3977097adc3caf2ec0857c18a989f841cb46a8d572b4b3fc8bd8cd4fb1d1e98ec8539c2f5baea49a21f68eb0b38d50a76e82da46ff734da7
+DIST List-MoreUtils-0.408.tar.gz 169922 SHA256 93bf92e2dd560b90e4acdc12c24ca80ac1452e4a33bebe7860d02eda4ba3b9e1 SHA512 786fc6e613ab3d19c02ef8b6a35405634124d55ccde6d52bf0169397599d8cab3e37a7ffa5eaf2fe83ba933958197aefad89e5cf7707b75b3e70f2dae23412bf WHIRLPOOL e8db1e6fa5915acfdaba1f9ab6bb5ebe8f2afd6dd6759fd2416e4004bcd990557189f4518dd31e37d6a2d669ed21a5f019b96726ab00f91f1edd2f6b2b3b37d4
+DIST List-MoreUtils-0.413.tar.gz 131313 SHA256 4d6429d5672ce74a59d6490320252cb8b5b8285db8fe9c6551a4162e5375ef37 SHA512 178c08995d2eddd75054b29cd68adb77617e92b7e56ac56a890eb7b8e04a1f8eda09f2208288d61352db563bff7da0accf58f7482906a51e03b38465ea655d17 WHIRLPOOL 843a54dc44e6698ced55e2737dc42c14327af5e76d25899e617cbec6fccceb4ddcf8ca424e641fa32be60b6b1878191ad3446c1f8477c7c751559799b3d871bc
diff --git a/dev-perl/List-MoreUtils/metadata.xml b/dev-perl/List-MoreUtils/metadata.xml
new file mode 100644
index 00000000000..39ba20d2822
--- /dev/null
+++ b/dev-perl/List-MoreUtils/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">List-MoreUtils</remote-id>
+ <remote-id type="cpan-module">List::MoreUtils</remote-id>
+ </upstream>
+</pkgmetadata>