summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-IMAPClient
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Mail-IMAPClient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Mail-IMAPClient')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.350.0.ebuild26
-rw-r--r--dev-perl/Mail-IMAPClient/Manifest1
-rw-r--r--dev-perl/Mail-IMAPClient/files/2.2.9-skiptest.patch11
-rw-r--r--dev-perl/Mail-IMAPClient/metadata.xml18
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.350.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.350.0.ebuild
new file mode 100644
index 00000000000..5e0a2932f11
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.350.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PLOBBES
+MODULE_VERSION=3.35
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Parse-RecDescent-1.940.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Mail-IMAPClient/Manifest b/dev-perl/Mail-IMAPClient/Manifest
new file mode 100644
index 00000000000..1fe1850074b
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Manifest
@@ -0,0 +1 @@
+DIST Mail-IMAPClient-3.35.tar.gz 186010 SHA256 8a4503833ce87d980be2d54603d94de4b365c2369eab19b095216506ce40f663 SHA512 c8fc11d098a0c0370347155e860e4eb1b0842c5de825f206d166bd6d99d510a492aa0ebe5a15f561aae1f379641f502fc4984660be2a0b42be52a01a58661595 WHIRLPOOL 264bb7cf85466a65a13184a1c008d8913f8b77af9954983e83b7eb5542747d5cf146fd6dc4d089020ab25183781e1394366d109b489973cf9ac7b4739fd0b017
diff --git a/dev-perl/Mail-IMAPClient/files/2.2.9-skiptest.patch b/dev-perl/Mail-IMAPClient/files/2.2.9-skiptest.patch
new file mode 100644
index 00000000000..11ccfb295cf
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/2.2.9-skiptest.patch
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig 2005-01-07 23:17:00.849874616 -0200
++++ Makefile.PL 2005-01-07 23:18:32.815893656 -0200
+@@ -49,7 +49,7 @@
+
+ sub set_test_data {
+ unless (-f "./IMAPClient.pm") { warn "ERROR: not in installation directory\n"; return }
+- return if -f "./test.txt";
++ return if -f "./Makefile.PL";
+ print "You have the option of running an extended suite of tests during\n",
+ "'make test'. This requires an IMAP server name, user account, and ",
+ "password to test with.","\n","\n",
diff --git a/dev-perl/Mail-IMAPClient/metadata.xml b/dev-perl/Mail-IMAPClient/metadata.xml
new file mode 100644
index 00000000000..0141a301dd2
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Mail-IMAPClient</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Address</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Envelope</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Parse</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::BodyStructure::Part</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::MessageSet</remote-id>
+ <remote-id type="cpan-module">Mail::IMAPClient::Thread</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Mail::IMAPClient::BodyStructure::Parse</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Mail::IMAPClient::Thread</remote-id>
+ </upstream>
+</pkgmetadata>