summaryrefslogtreecommitdiff
path: root/dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-16 13:02:32 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-16 23:49:45 +0100
commitd7a1346ab345278564d6ec60581639ade8646a53 (patch)
tree071212718646804e6bc3211993d2969ddedb22a5 /dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild
parent466f5fdfd7ebd648800aa0840627b27a1c5dc8b8 (diff)
downloadgentoo-d7a1346ab345278564d6ec60581639ade8646a53.tar.gz
gentoo-d7a1346ab345278564d6ec60581639ade8646a53.tar.xz
dev-perl/Params-Validate: Bump to version 1.220.0
Upstream: - Bugs fixed in error handling and error message formatting Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild')
-rw-r--r--dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild b/dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild
new file mode 100644
index 00000000000..b0f37164996
--- /dev/null
+++ b/dev-perl/Params-Validate/Params-Validate-1.220.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.22
+inherit perl-module
+
+DESCRIPTION="Flexible system for validation of method/function call parameters"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ >=virtual/perl-JSON-PP-2.273.0
+ dev-perl/Module-Implementation
+ >=virtual/perl-Scalar-List-Utils-1.110.0
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Requires
+ )
+"