summaryrefslogtreecommitdiff
path: root/dev-perl/SDL
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/SDL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/SDL')
-rw-r--r--dev-perl/SDL/Manifest2
-rw-r--r--dev-perl/SDL/SDL-2.540-r1.ebuild41
-rw-r--r--dev-perl/SDL/SDL-2.544.ebuild41
-rw-r--r--dev-perl/SDL/metadata.xml91
4 files changed, 175 insertions, 0 deletions
diff --git a/dev-perl/SDL/Manifest b/dev-perl/SDL/Manifest
new file mode 100644
index 00000000000..b8dda29daf6
--- /dev/null
+++ b/dev-perl/SDL/Manifest
@@ -0,0 +1,2 @@
+DIST SDL-2.540.tar.gz 2490785 SHA256 031866be84e6bbd7bb082aed26265ad64f84dc867db5239476921746a41e6a1f SHA512 6c85ea179174415da40fe20f27086626b56570d8dbb6416957fb3236550d27ad893f171c7aedf7c6cda2ca6f2078dfad5d8813e428b49c920c1f8487416193b3 WHIRLPOOL 1cf79640cf56237f7ed439cd2c13ef60e4978762867495d50ad7db06f75685022fb4409265ef4243bdb688c467eb66acbeab40e18ee5f688511f1e60a52894f9
+DIST SDL-2.544.tar.gz 2487263 SHA256 3878d7171c7fb34b5d35f9ef3883e532fb44188c666f7492ce2bf14f5acad096 SHA512 df8a6cc1f395e143bfa59f08a0c91c640b83463742250f5ea545dcde1d7b3f819dcae03535e62f572ae2d7ad3bbc988b034a1c83a451926f6ec2d5e11ae90ddc WHIRLPOOL 667675bb12a3b6957848de0616f158f36b9f6a14b5ea0af68e3f14839dc8b24a810b51b3f06fc2f3695a060991ae58fdb9f75ba7d221e42c51032752b0592b71
diff --git a/dev-perl/SDL/SDL-2.540-r1.ebuild b/dev-perl/SDL/SDL-2.540-r1.ebuild
new file mode 100644
index 00000000000..ab2a58ef261
--- /dev/null
+++ b/dev-perl/SDL/SDL-2.540-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=JTPALMER
+inherit perl-module
+
+DESCRIPTION="Simple DirectMedia Layer (SDL) bindings for perl"
+HOMEPAGE="http://sdl.perl.org/ http://search.cpan.org/dist/SDL/ http://github.com/PerlGameDev/SDL"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/Alien-SDL-1.434
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/Test-Most
+ dev-perl/Tie-Simple
+ media-libs/libpng:0
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ media-libs/smpeg
+ media-libs/tiff:0
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.400.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+mydoc='CHANGELOG README TODO'
diff --git a/dev-perl/SDL/SDL-2.544.ebuild b/dev-perl/SDL/SDL-2.544.ebuild
new file mode 100644
index 00000000000..3f10fabb81d
--- /dev/null
+++ b/dev-perl/SDL/SDL-2.544.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=FROGGS
+inherit perl-module
+
+DESCRIPTION="Simple DirectMedia Layer (SDL) bindings for perl"
+HOMEPAGE="http://sdl.perl.org/ http://search.cpan.org/dist/SDL/ http://github.com/PerlGameDev/SDL"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/Alien-SDL-1.434
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/Test-Most
+ dev-perl/Tie-Simple
+ media-libs/libpng:0
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ media-libs/smpeg
+ media-libs/tiff:0
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.400.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+mydoc='CHANGELOG README TODO'
diff --git a/dev-perl/SDL/metadata.xml b/dev-perl/SDL/metadata.xml
new file mode 100644
index 00000000000..0450ff5895b
--- /dev/null
+++ b/dev-perl/SDL/metadata.xml
@@ -0,0 +1,91 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="cpan">SDL</remote-id>
+ <remote-id type="cpan-module">Module::Build::SDL</remote-id>
+ <remote-id type="cpan-module">SDL</remote-id>
+ <remote-id type="cpan-module">SDL::Audio</remote-id>
+ <remote-id type="cpan-module">SDL::AudioCVT</remote-id>
+ <remote-id type="cpan-module">SDL::AudioSpec</remote-id>
+ <remote-id type="cpan-module">SDL::CD</remote-id>
+ <remote-id type="cpan-module">SDL::CDROM</remote-id>
+ <remote-id type="cpan-module">SDL::CDTrack</remote-id>
+ <remote-id type="cpan-module">SDL::Color</remote-id>
+ <remote-id type="cpan-module">SDL::Config</remote-id>
+ <remote-id type="cpan-module">SDL::Constants</remote-id>
+ <remote-id type="cpan-module">SDL::Cursor</remote-id>
+ <remote-id type="cpan-module">SDL::Event</remote-id>
+ <remote-id type="cpan-module">SDL::Events</remote-id>
+ <remote-id type="cpan-module">SDL::GFX</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::BlitFunc</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::FPSManager</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::Framerate</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::ImageFilter</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::Primitives</remote-id>
+ <remote-id type="cpan-module">SDL::GFX::Rotozoom</remote-id>
+ <remote-id type="cpan-module">SDL::Image</remote-id>
+ <remote-id type="cpan-module">SDL::Internal::Loader</remote-id>
+ <remote-id type="cpan-module">SDL::Joystick</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::Channels</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::Effects</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::Groups</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::MixChunk</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::MixMusic</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::Music</remote-id>
+ <remote-id type="cpan-module">SDL::Mixer::Samples</remote-id>
+ <remote-id type="cpan-module">SDL::Mouse</remote-id>
+ <remote-id type="cpan-module">SDL::MultiThread</remote-id>
+ <remote-id type="cpan-module">SDL::Net</remote-id>
+ <remote-id type="cpan-module">SDL::Net::IPaddress</remote-id>
+ <remote-id type="cpan-module">SDL::Net::TCP</remote-id>
+ <remote-id type="cpan-module">SDL::Net::UDP</remote-id>
+ <remote-id type="cpan-module">SDL::Overlay</remote-id>
+ <remote-id type="cpan-module">SDL::Palette</remote-id>
+ <remote-id type="cpan-module">SDL::Pango</remote-id>
+ <remote-id type="cpan-module">SDL::Pango::Context</remote-id>
+ <remote-id type="cpan-module">SDL::PixelFormat</remote-id>
+ <remote-id type="cpan-module">SDL::RWOps</remote-id>
+ <remote-id type="cpan-module">SDL::Rect</remote-id>
+ <remote-id type="cpan-module">SDL::SMPEG</remote-id>
+ <remote-id type="cpan-module">SDL::SMPEG::Info</remote-id>
+ <remote-id type="cpan-module">SDL::Surface</remote-id>
+ <remote-id type="cpan-module">SDL::TTF</remote-id>
+ <remote-id type="cpan-module">SDL::TTF::Font</remote-id>
+ <remote-id type="cpan-module">SDL::TTFont</remote-id>
+ <remote-id type="cpan-module">SDL::Time</remote-id>
+ <remote-id type="cpan-module">SDL::Tutorial</remote-id>
+ <remote-id type="cpan-module">SDL::Tutorial::Animation</remote-id>
+ <remote-id type="cpan-module">SDL::Tutorial::LunarLander</remote-id>
+ <remote-id type="cpan-module">SDL::Version</remote-id>
+ <remote-id type="cpan-module">SDL::Video</remote-id>
+ <remote-id type="cpan-module">SDL::VideoInfo</remote-id>
+ <remote-id type="cpan-module">SDL_perl</remote-id>
+ <remote-id type="cpan-module">SDLx::App</remote-id>
+ <remote-id type="cpan-module">SDLx::Controller</remote-id>
+ <remote-id type="cpan-module">SDLx::Controller::Interface</remote-id>
+ <remote-id type="cpan-module">SDLx::Controller::State</remote-id>
+ <remote-id type="cpan-module">SDLx::Controller::Timer</remote-id>
+ <remote-id type="cpan-module">SDLx::FPS</remote-id>
+ <remote-id type="cpan-module">SDLx::Layer</remote-id>
+ <remote-id type="cpan-module">SDLx::LayerManager</remote-id>
+ <remote-id type="cpan-module">SDLx::Music</remote-id>
+ <remote-id type="cpan-module">SDLx::Music::Data</remote-id>
+ <remote-id type="cpan-module">SDLx::Music::Default</remote-id>
+ <remote-id type="cpan-module">SDLx::Rect</remote-id>
+ <remote-id type="cpan-module">SDLx::SFont</remote-id>
+ <remote-id type="cpan-module">SDLx::Sound</remote-id>
+ <remote-id type="cpan-module">SDLx::Sprite</remote-id>
+ <remote-id type="cpan-module">SDLx::Sprite::Animated</remote-id>
+ <remote-id type="cpan-module">SDLx::Surface</remote-id>
+ <remote-id type="cpan-module">SDLx::Surface::TiedMatrix</remote-id>
+ <remote-id type="cpan-module">SDLx::Surface::TiedMatrixRow</remote-id>
+ <remote-id type="cpan-module">SDLx::TTF</remote-id>
+ <remote-id type="cpan-module">SDLx::Text</remote-id>
+ <remote-id type="cpan-module">SDLx::Validate</remote-id>
+ <remote-id type="github">PerlGameDev/SDL</remote-id>
+ </upstream>
+</pkgmetadata>