summaryrefslogtreecommitdiff
path: root/dev-perl/UUID/UUID-0.250.0.ebuild
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-25 23:51:02 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-26 22:02:54 +0200
commit75ea92ab6cdcb3a19bdcf3a7a5eb07c3cb4c20f9 (patch)
treedb7e7f731bce96805b024e0d4fec09cd2b1c8912 /dev-perl/UUID/UUID-0.250.0.ebuild
parent24aeca8d0002c37987e93b9d53ddfc3e6528c450 (diff)
downloadgentoo-75ea92ab6cdcb3a19bdcf3a7a5eb07c3cb4c20f9.tar.gz
gentoo-75ea92ab6cdcb3a19bdcf3a7a5eb07c3cb4c20f9.tar.xz
dev-perl/UUID: Bump to version 0.250.0
- EAPI6 - Switch License to artistic-2 Upstream: - New functions: uuid(), clear(), is_null(), copy(), compare(), unparse_lower(), unparse_upper(), generate_random(), generate_time() Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/UUID/UUID-0.250.0.ebuild')
-rw-r--r--dev-perl/UUID/UUID-0.250.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/UUID/UUID-0.250.0.ebuild b/dev-perl/UUID/UUID-0.250.0.ebuild
new file mode 100644
index 00000000000..fa965433bf0
--- /dev/null
+++ b/dev-perl/UUID/UUID-0.250.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+DIST_AUTHOR=JRM
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Perl extension for using UUID interfaces as defined in e2fsprogs"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Note: UUID appears to link against a bunch of different UUID
+# implementations depending on availability and platform.
+#
+# Presently uses uuid.h/libuuid.so from util-linux which is fine for Linux
+# platforms, but may need special attention on *bsd, *osx and win*
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Devel-CheckLib-1.20.0
+"