summaryrefslogtreecommitdiff
path: root/dev-perl/tie-encryptedhash
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/tie-encryptedhash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/tie-encryptedhash')
-rw-r--r--dev-perl/tie-encryptedhash/Manifest1
-rw-r--r--dev-perl/tie-encryptedhash/metadata.xml9
-rw-r--r--dev-perl/tie-encryptedhash/tie-encryptedhash-1.240.0-r1.ebuild23
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/tie-encryptedhash/Manifest b/dev-perl/tie-encryptedhash/Manifest
new file mode 100644
index 00000000000..a365209613b
--- /dev/null
+++ b/dev-perl/tie-encryptedhash/Manifest
@@ -0,0 +1 @@
+DIST Tie-EncryptedHash-1.24.tar.gz 10515 SHA256 aa9a083a231e4046170a5894644e3c59679c7dbd0aa2d1217dc85150df2c1e21 SHA512 1b86af7ed2854f8b5a9f03f22484ecb08021efd87993b3f5786a56764478e022d5e2f2cbb87d4a832743a05e1983174481b95d3545175106a44b9911fc8adef7 WHIRLPOOL cf22bba9053719ff45d50556269af41b019124f91a2907c69bd7f63bc9db5f05edfa15efb559d7248a4514c0a5389f3f941ec459523c1e0d4a716265ce6998c6
diff --git a/dev-perl/tie-encryptedhash/metadata.xml b/dev-perl/tie-encryptedhash/metadata.xml
new file mode 100644
index 00000000000..dde200155ce
--- /dev/null
+++ b/dev-perl/tie-encryptedhash/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Tie-EncryptedHash</remote-id>
+ <remote-id type="cpan-module">Tie::EncryptedHash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-perl/tie-encryptedhash/tie-encryptedhash-1.240.0-r1.ebuild b/dev-perl/tie-encryptedhash/tie-encryptedhash-1.240.0-r1.ebuild
new file mode 100644
index 00000000000..cf3fd1f9600
--- /dev/null
+++ b/dev-perl/tie-encryptedhash/tie-encryptedhash-1.240.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Tie-EncryptedHash
+MODULE_AUTHOR=VIPUL
+MODULE_VERSION=1.24
+inherit perl-module
+
+DESCRIPTION="Hashes (and objects based on hashes) with encrypting fields"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES
+ dev-perl/crypt-cbc"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do