summaryrefslogtreecommitdiff
path: root/dev-perl
diff options
context:
space:
mode:
authorMarshall Brewer <tomboy64@sina.cn>2016-06-03 19:32:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-04 10:03:42 +0000
commit5161f1dccfa1dfcf59014da53ae52f989ae336c9 (patch)
tree484da9d1b96714f041aabce5b399eae2141d7a89 /dev-perl
parent15a9e03c028f3db9a4c1c591995949f25f997bac (diff)
downloadgentoo-5161f1dccfa1dfcf59014da53ae52f989ae336c9.tar.gz
gentoo-5161f1dccfa1dfcf59014da53ae52f989ae336c9.tar.xz
dev-perl/Math-PlanePath: version bump 123
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1599 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Math-PlanePath/Manifest1
-rw-r--r--dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Math-PlanePath/Manifest b/dev-perl/Math-PlanePath/Manifest
index be529564e85..28c005d0906 100644
--- a/dev-perl/Math-PlanePath/Manifest
+++ b/dev-perl/Math-PlanePath/Manifest
@@ -1 +1,2 @@
DIST Math-PlanePath-122.tar.gz 1290711 SHA256 edcf64f5cb9e4cca6dd6ee88c285551ee5151438c041cdeb41a4af88f184452f SHA512 06983ab17b50da9a6872a0c154e433736720c40fc2f845de606f7089697d00d22bc1b9a8580292258af0d3d6e1133363ec2894269ed472f1fb4e52f0af2709ed WHIRLPOOL 23576d1f5d74dd5753ac236a4cf4fc1de6df25950746c78211408389e3845f3bfe3610b7f2005ff2f20c4b8874ee1977498cf027e392b3de37f9f9296ac19a22
+DIST Math-PlanePath-123.tar.gz 1284214 SHA256 cc77cb05ad63cd10b534d8b5cf5c1d99a2d5315d47f3d8f3704239feef107e8d SHA512 5289f674dd62f668e667d69baf52d2f6d8b8fcf4ce6bed1429ef1fb412f2415b474103ca9b6d9c5b876b6926d860f70834e26c68a30b53d2211cbc4c457e2b43 WHIRLPOOL f9eaff401e35c8d99e69ef920bf28f5036d96f4991e2633a12f2559e2e7e3536b1004677fbeb9baf851451bf029ab8a560ad90b6c4264f1a7ac41d89b402d0d8
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild
new file mode 100644
index 00000000000..75928a48c82
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Math-PlanePath-123.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION="123"
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp test examples"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+ dev-perl/Math-Libm
+ dev-perl/Math-NumSeq
+ >=dev-perl/constant-defer-5.0.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test
+ dev-perl/Math-BigInt-Lite
+ dev-perl/Number-Fraction )"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}