summaryrefslogtreecommitdiff
path: root/dev-perl
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-10-03 03:49:32 +1300
committerKent Fredric <kentnl@gentoo.org>2016-10-03 05:02:16 +1300
commite3e3fa8bf0a23417959541cb54c1b098f4067e26 (patch)
tree321862f48a1ffdeb70d02b6ed24127300bb15bf3 /dev-perl
parent0db830d65adfc2627be610e237da6f40df58b44c (diff)
downloadgentoo-e3e3fa8bf0a23417959541cb54c1b098f4067e26.tar.gz
gentoo-e3e3fa8bf0a23417959541cb54c1b098f4067e26.tar.xz
dev-perl/DBD-mysql: Bump to version 4.36.0 re bug #589818 & bug #587206
- EAPI6 - Bad tests pruned - USE="ssl" added - DESCRIPTION updated. Note: - USE="ssl" is only partial because there's no straight-forward way to ensure that the client library ( which is hidden behind virtual/mysql ) itself has ssl support. If the backend does not have ssl support, it will be silently disabled! Upstream: - Compatibility fixes for older MySQL versions - use-after-free fixes - Fixed memory leak in sth->{ParamValues} - SSL support turned on by default (implemented via libmysqlclient) - Check errors after calling mysql_affected_rows - Tests fixed on bigendian systems Bug: https://bugs.gentoo.org/587206 Bug: https://bugs.gentoo.org/589818 Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.36.0.ebuild68
-rw-r--r--dev-perl/DBD-mysql/Manifest1
-rw-r--r--dev-perl/DBD-mysql/metadata.xml1
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.36.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.36.0.ebuild
new file mode 100644
index 00000000000..86b05ba8acc
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.36.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MICHIELB
+DIST_VERSION=4.036
+inherit eutils perl-module
+
+DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# embedded=on disables ssl support
+# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
+REQUIRED_USE="?? ( embedded ssl )"
+IUSE="embedded test +ssl"
+
+RDEPEND=">=dev-perl/DBI-1.609.0
+ virtual/mysql[embedded?]
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Data-Dumper
+ test? (
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.900.0
+ virtual/perl-Time-HiRes
+ )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-print_embedded_options.patch
+)
+
+src_configure() {
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ myconf="${myconf} --$(usex ssl ssl nossl)"
+ use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
+ perl-module_src_configure
+}
+
+# Parallel testing is broken as 2 tests create the same table
+# and mysql isn't acid compliant and can't limit visibility of tables
+# to a transaction...
+DIST_TEST="do"
+
+src_test() {
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl_rm_files t/pod.t t/manifest.t
+ # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
+ # out why 60leaks.t fails
+ perl-module_src_test
+}
diff --git a/dev-perl/DBD-mysql/Manifest b/dev-perl/DBD-mysql/Manifest
index db6437eec44..68861309b81 100644
--- a/dev-perl/DBD-mysql/Manifest
+++ b/dev-perl/DBD-mysql/Manifest
@@ -1 +1,2 @@
DIST DBD-mysql-4.032.tar.gz 146476 SHA256 b8e681e719d8f2d1cecb9e8603e13483b09b56508629b079022778e7dfd7bfb6 SHA512 7e7ebaed07f0540079854294cc3ab4a4554fd0f850dd0927b2485cc985c2c9f5b70a650d971027c883cc4d8450020245656f6ff1f792a56d1a2d4b45402d73d0 WHIRLPOOL 79b94c7c85406e0f3a0469c8017594f81f6151eab3059d483c50326222fdb920d12db04a5382dbdc2862cf853e1c421fe0d7acc4a35b131a0f9d39c2d79f5d0b
+DIST DBD-mysql-4.036.tar.gz 146513 SHA256 5c48a823f86b8110ccb6504c6176ca248b52f56829dd4548bc39c3509f4154cf SHA512 2bfc5151b54559277f5e1949abc702eb373323998c641d199e3b2ba30f4b4ca449fc728fbd4f5ed05af53602e8f8772c2de9b1dd6db36f5af85a3c7799daab19 WHIRLPOOL db173ca8ce560bdbf4120b992c7ebb40feb73a3bd12b1a4f773a5ae7f4daadb77f65111cd3b97329470eaf1f9b7702d0a501180bb12ad622892126cb8e1fcd3d
diff --git a/dev-perl/DBD-mysql/metadata.xml b/dev-perl/DBD-mysql/metadata.xml
index a240c445315..8b79ff55907 100644
--- a/dev-perl/DBD-mysql/metadata.xml
+++ b/dev-perl/DBD-mysql/metadata.xml
@@ -16,5 +16,6 @@
</upstream>
<use>
<flag name="embedded">Support embedded server (libmysqld)</flag>
+ <flag name="ssl">Compile in support for SSL connections via libmysqlclient</flag>
</use>
</pkgmetadata>