summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-PHP_Shell
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-PHP_Shell
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-PHP_Shell')
-rw-r--r--dev-php/PEAR-PHP_Shell/Manifest1
-rw-r--r--dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.2.ebuild31
-rw-r--r--dev-php/PEAR-PHP_Shell/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/PEAR-PHP_Shell/Manifest b/dev-php/PEAR-PHP_Shell/Manifest
new file mode 100644
index 00000000000..6aab774452f
--- /dev/null
+++ b/dev-php/PEAR-PHP_Shell/Manifest
@@ -0,0 +1 @@
+DIST PHP_Shell-0.3.2.tgz 99252 SHA256 d17c4986ebb5124a056c314d08be98f6b8b23ce1859b8683f105db4be76c02b5 SHA512 aa2779c4d3d793b4658d866c58a7cf66c0536f3fa44ab8381cf889712854403af2a46a109699f52f0eba07687fa6c0f8202b3c32f9d8e9cef9568fa3d0606c33 WHIRLPOOL 1ee8a6f29f2379977c5db3a0766f6017301b42ea63190934e285cd9cdd32951a9a35cb79bb1d5bd7437b3a7ecf50845688462f79e3602bb1ad8f81ae72d4ed23
diff --git a/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.2.ebuild b/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.2.ebuild
new file mode 100644
index 00000000000..3c97bba8e42
--- /dev/null
+++ b/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit php-pear-r1
+
+DESCRIPTION="A shell for PHP with history and tab-completion"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="auto-completion"
+
+RDEPEND=">=dev-lang/php-5.3[tokenizer]
+ auto-completion? ( dev-lang/php[readline] )"
+
+src_prepare() {
+ # Fill in Gentoo values for placeholders
+ sed -i -e "s~@php_bin@~${EPREFIX}/usr/bin/php~" \
+ -e "s~@php_dir@~${EPREFIX}/usr/share/php/scripts~" "${S}/scripts/php-shell.sh" || die
+ # Fix version value. Upstream forgot to update in code but made a release anyway
+ sed -i "s/$version = '0.3.1'/$version = '0.3.2'/" "${S}/PHP/Shell.php" || die
+}
+
+src_install() {
+ php-pear-r1_src_install
+ dobin scripts/php-shell.sh
+ dosym php-shell.sh /usr/bin/php-shell
+}
diff --git a/dev-php/PEAR-PHP_Shell/metadata.xml b/dev-php/PEAR-PHP_Shell/metadata.xml
new file mode 100644
index 00000000000..258d1b7b477
--- /dev/null
+++ b/dev-php/PEAR-PHP_Shell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <use>
+ <flag name='auto-completion'>Enable tab-completion</flag>
+ </use>
+</pkgmetadata>