summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_Wiki
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-14 13:28:10 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-14 13:53:41 -0500
commite3d639fcef6946b1c57126c77f6894f9d43a2dc0 (patch)
tree688eb15991e4412626b15519b3adcd5c1b057178 /dev-php/PEAR-Text_Wiki
parent4f6eabc0ede1db5db4e32cbd532120e22f47f95f (diff)
downloadgentoo-e3d639fcef6946b1c57126c77f6894f9d43a2dc0.tar.gz
gentoo-e3d639fcef6946b1c57126c77f6894f9d43a2dc0.tar.xz
dev-php/PEAR-Text_Wiki: Add upstream patches direct to stable
The released version no longer works with modern PHP. This snapshot allows the package to continue. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Text_Wiki')
-rw-r--r--dev-php/PEAR-Text_Wiki/Manifest1
-rw-r--r--dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Wiki/Manifest b/dev-php/PEAR-Text_Wiki/Manifest
index ba60722ce1c..a582a428c6f 100644
--- a/dev-php/PEAR-Text_Wiki/Manifest
+++ b/dev-php/PEAR-Text_Wiki/Manifest
@@ -1 +1,2 @@
DIST PEAR-Text_Wiki-1.2.2.tar.gz 82036 BLAKE2B 898d62c448352fb7e6d4877852ce45200ac676a5f6fb18987ab602428ef495f23ef37f6f1fb0538a644f3679e0dbbfdceec65698a7282d2ab2807d0f8126d102 SHA512 c799245d297349ed73f81997ce1c38f24b7dde18bd7535089275c467deed284de9daff6b4fbfb5728771b227e05dee42a00366e655715a1cc0baa807fea02320
+DIST Text_Wiki-1.2.2_p20170904.tar.gz 86810 BLAKE2B 3277fbfae5683c147c1537a7f789b8b9500bfa39014832ed08d91028882813f60727f9ff503d38dde5f017fd5f1ec69d61775a14094b0d267a1b0019f10090c8 SHA512 8e731a6cc9ec0e964d86de5eb96f285155f61d21e229499132f5b06ef8ff520658a42c9c6fb60d73b9bc8828ec9b616bc11e4f04bdd6e74836d52fc53a92dd71
diff --git a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
new file mode 100644
index 00000000000..cf72e330dc7
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Abstracts parsing and rendering rules for Wiki markup in structured plain text"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+# Pull from github as pear.php.net is not updated
+SRC_URI="https://github.com/pear/${PHP_PEAR_PKG_NAME}/archive/32fd5f483f34645f4efd96d385d8950ea26d4a2a.tar.gz -> ${PEAR_P}.tar.gz"
+
+DEPEND="test? ( dev-php/phpunit dev-php/PEAR-PEAR )"
+
+src_test() {
+ peardev run-tests tests || die
+ phpunit tests/*.php || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/.packagexml
+ newins package.xml "${PEAR_P}.xml"
+}