summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-10-27 20:03:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2018-10-27 20:03:06 -0400
commit204d8c576d425dd08b9b094027a4fbbb0c285d6d (patch)
treeb38b5416ff2c68698ffc01a4aabc723a0ccda943 /dev-php/PHPMailer
parente8488b03e7d0fdd2e982bd4b7efb93ca744fac3a (diff)
downloadgentoo-204d8c576d425dd08b9b094027a4fbbb0c285d6d.tar.gz
gentoo-204d8c576d425dd08b9b094027a4fbbb0c285d6d.tar.xz
dev-php/PHPMailer: new version 6.0.5.
Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.0.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 405e395db4f..762981e24e2 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1 +1,2 @@
DIST PHPMailer-5.2.26.tar.gz 159174 BLAKE2B 989ee85f6ca374bd7f4accf3d18fbd173bbbd3176e6846c9a2aec68f3bfca4ead4e0197f6287e2bc8ed4a125bf7fcb53240a1f8ce6a1813eaffb66067c2c4e9e SHA512 4c3e324ecd1dd23eb40f14ee785fb9b353b742ff4fb26fe0586622038157e60d64560f5ba4a625f16fad6568954d685ebbe436d88bc427d5bd260c056815b656
+DIST PHPMailer-6.0.5.tar.gz 88092 BLAKE2B 0b2113b54d547d788c54cbcf18fe134a6b08f6b9eabcbad308a7d0bba8e95426fd8be77419419cbe0379be080350a1caf1690cbe3f096c178cc3a8c9506d9529 SHA512 5b18700ef26fe5de20a7ca291ece44b897182c603ed8187e0f711099325b35b20f8dbab2c456eaac1338731356661237d9b249c2f40051807b0d58ead612013c
diff --git a/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild b/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild
new file mode 100644
index 00000000000..99907db766f
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+ eapply_user
+}
+
+src_compile(){
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install(){
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}