summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-12-21 23:01:37 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-12-21 23:26:59 -0500
commit3e0626ba870b97a5258731cc582379824d8d9b53 (patch)
tree4ebbb6ed83ee6ab9a72a432dcc0beb8b756225b5 /dev-php/PHPMailer
parent22223f779fe291737a327a1f449495d3a51fb475 (diff)
downloadgentoo-3e0626ba870b97a5258731cc582379824d8d9b53.tar.gz
gentoo-3e0626ba870b97a5258731cc582379824d8d9b53.tar.xz
dev-php/PHPMailer: another revision to sort out PHP extension deps.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild (renamed from dev-php/PHPMailer/PHPMailer-5.2.26-r1.ebuild)21
1 files changed, 19 insertions, 2 deletions
diff --git a/dev-php/PHPMailer/PHPMailer-5.2.26-r1.ebuild b/dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild
index 152762c2a1f..1cd077177b3 100644
--- a/dev-php/PHPMailer/PHPMailer-5.2.26-r1.ebuild
+++ b/dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild
@@ -10,9 +10,26 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc +examples"
+IUSE="doc examples idn ssl"
-RDEPEND="dev-lang/php:*[ctype,filter,ssl]"
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
DEPEND="${RDEPEND}
doc? ( dev-php/phpDocumentor )"