summaryrefslogtreecommitdiff
path: root/dev-php/mockery
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/mockery
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/mockery')
-rw-r--r--dev-php/mockery/Manifest1
-rw-r--r--dev-php/mockery/files/channel.xml16
-rw-r--r--dev-php/mockery/metadata.xml8
-rw-r--r--dev-php/mockery/mockery-0.9.0.ebuild20
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/mockery/Manifest b/dev-php/mockery/Manifest
new file mode 100644
index 00000000000..1d19cff171f
--- /dev/null
+++ b/dev-php/mockery/Manifest
@@ -0,0 +1 @@
+DIST Mockery-0.9.0.tgz 30330 SHA256 6f6fda75362c4092b8628158bd90302f8a3a9865cd692f99211dcaa56da73bf3 SHA512 744f7727395feb1009ae879dd9f336a314c70d96e848efe19c399d3abee42950606352a0781a1664178f77485933491928a1bddbcdb86a5092d69434868eee1c WHIRLPOOL fbf2d541c5456b907c184a50c7349743caa271d8112f93aa634f0e99f5a4621cef2accf6a3dc65b96e1d3bc0c00f6538b374fb7d38acaf38dc3aa644632178f8
diff --git a/dev-php/mockery/files/channel.xml b/dev-php/mockery/files/channel.xml
new file mode 100644
index 00000000000..b9fe38d87b1
--- /dev/null
+++ b/dev-php/mockery/files/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.survivethedeepend.com</name>
+ <summary>Survive The Deep End PEAR Channel</summary>
+ <suggestedalias>deepend</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.survivethedeepend.com/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.survivethedeepend.com/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.survivethedeepend.com/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.survivethedeepend.com/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/dev-php/mockery/metadata.xml b/dev-php/mockery/metadata.xml
new file mode 100644
index 00000000000..388a8fe2dad
--- /dev/null
+++ b/dev-php/mockery/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="github">padraic/mockery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/mockery/mockery-0.9.0.ebuild b/dev-php/mockery/mockery-0.9.0.ebuild
new file mode 100644
index 00000000000..b289b7ea651
--- /dev/null
+++ b/dev-php/mockery/mockery-0.9.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_PN="Mockery"
+PHP_PEAR_URI="pear.survivethedeepend.com"
+inherit php-pear-lib-r1
+
+DESCRIPTION="Simple yet flexible PHP mock object framework for use in unit testing"
+HOMEPAGE="https://github.com/padraic/mockery"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""