summaryrefslogtreecommitdiff
path: root/dev-php/pear
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pear
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pear')
-rw-r--r--dev-php/pear/metadata.xml5
-rw-r--r--dev-php/pear/pear-1.9.4.ebuild42
-rw-r--r--dev-php/pear/pear-1.9.5.ebuild42
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-php/pear/metadata.xml b/dev-php/pear/metadata.xml
new file mode 100644
index 00000000000..fd3dbe39fa6
--- /dev/null
+++ b/dev-php/pear/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pear/pear-1.9.4.ebuild b/dev-php/pear/pear-1.9.4.ebuild
new file mode 100644
index 00000000000..2be0389d57a
--- /dev/null
+++ b/dev-php/pear/pear-1.9.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+
+DESCRIPTION="PEAR - PHP Extension and Application Repository"
+HOMEPAGE="http://pear.php.net/"
+SRC_URI=""
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+S="${WORKDIR}"
+
+DEPEND="!<dev-php/PEAR-PEAR-1.8.1
+ ~dev-php/PEAR-PEAR-${PV}
+ >=dev-php/PEAR-Archive_Tar-1.3.7
+ >=dev-php/PEAR-Console_Getopt-1.2.3
+ >=dev-php/PEAR-Structures_Graph-1.0.2
+ >=dev-php/PEAR-XML_Util-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ :;
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ elog "Updating PEAR/PECL channels"
+ local pearchans="pear.php.net pecl.php.net components.ez.no
+ pear.propelorm.org pear.phing.info pear.symfony-project.com
+ pear.phpontrax.com pear.agavi.org"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/pear/pear-1.9.5.ebuild b/dev-php/pear/pear-1.9.5.ebuild
new file mode 100644
index 00000000000..11ccde9cb48
--- /dev/null
+++ b/dev-php/pear/pear-1.9.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR - PHP Extension and Application Repository"
+HOMEPAGE="http://pear.php.net/"
+SRC_URI=""
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+S="${WORKDIR}"
+
+DEPEND="!<dev-php/PEAR-PEAR-1.8.1
+ ~dev-php/PEAR-PEAR-${PV}
+ >=dev-php/PEAR-Archive_Tar-1.3.7
+ >=dev-php/PEAR-Console_Getopt-1.2.3
+ >=dev-php/PEAR-Structures_Graph-1.0.2
+ >=dev-php/PEAR-XML_Util-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ :;
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ elog "Updating PEAR/PECL channels"
+ local pearchans="pear.php.net pecl.php.net components.ez.no
+ pear.propelorm.org pear.phing.info pear.symfony-project.com
+ pear.phpontrax.com pear.agavi.org"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}