summaryrefslogtreecommitdiff
path: root/dev-php/pecl-geoip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-geoip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-geoip')
-rw-r--r--dev-php/pecl-geoip/Manifest2
-rw-r--r--dev-php/pecl-geoip/metadata.xml5
-rw-r--r--dev-php/pecl-geoip/pecl-geoip-1.0.8-r2.ebuild24
-rw-r--r--dev-php/pecl-geoip/pecl-geoip-1.1.0.ebuild24
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/pecl-geoip/Manifest b/dev-php/pecl-geoip/Manifest
new file mode 100644
index 00000000000..eac1185eed1
--- /dev/null
+++ b/dev-php/pecl-geoip/Manifest
@@ -0,0 +1,2 @@
+DIST geoip-1.0.8.tgz 10061 SHA256 08beeb2cbe9ab729d06b026795f5b9084aead6a1762493b0be53c4393d68d08a SHA512 3a8a64f1d420472cc5b3a760391be28bd6bd8a34092715b0f75f308502fa76ca71a029cb2f0ba2fb87ba26166781547edbb7f151609c91db48bb025add4d0447 WHIRLPOOL a79497cd4f9fe0bc8c50138a1c17ff4b0d08b615f6458a8b48149dccfbb7d5927c6cdb47ece5127ae477796d5a7ca2e38139fe71266584a5874b043d6a12ff95
+DIST geoip-1.1.0.tgz 12714 SHA256 82c6deb7264d2ff7c4d6c45a7d27cff7ab097be965795e317e04a9c5b7be98b9 SHA512 8a0fc698a234d3b2c01f2a0c05c28025d98a5d3dce509ba19ee462abae0fd0f5631d96d3e8bba4fce6c23b278ec3875da5e8535971c7d880e2e307a097dc30a1 WHIRLPOOL f8ccf90958bdc0eee41f24b6ad04907884fed2efe2bca483fa816aceb46d15311325175b07f27d85085afdb5651fd071fd20b046ba42e30da26eea56a14912d6
diff --git a/dev-php/pecl-geoip/metadata.xml b/dev-php/pecl-geoip/metadata.xml
new file mode 100644
index 00000000000..fd3dbe39fa6
--- /dev/null
+++ b/dev-php/pecl-geoip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-geoip/pecl-geoip-1.0.8-r2.ebuild b/dev-php/pecl-geoip/pecl-geoip-1.0.8-r2.ebuild
new file mode 100644
index 00000000000..b16a49629cf
--- /dev/null
+++ b/dev-php/pecl-geoip/pecl-geoip-1.0.8-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="geoip"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="PHP extension to map IP address to geographic places"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/geoip-1.4.0"
+RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-geoip/pecl-geoip-1.1.0.ebuild b/dev-php/pecl-geoip/pecl-geoip-1.1.0.ebuild
new file mode 100644
index 00000000000..27882740186
--- /dev/null
+++ b/dev-php/pecl-geoip/pecl-geoip-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="geoip"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="PHP extension to map IP address to geographic places"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/geoip-1.4.0"
+RDEPEND="${DEPEND}"