summaryrefslogtreecommitdiff
path: root/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-27 14:11:45 -0400
committerBrian Evans <grknight@gentoo.org>2018-03-27 14:19:47 -0400
commit03c4e92a7e4c42dbdbbe118e526ecadecf2cf22b (patch)
tree4854155e28a7c6f924c8991e27a3584e18d58364 /dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild
parentdf67b5aa9973f2f4e9b821ef80c2ab2684fa323c (diff)
downloadgentoo-03c4e92a7e4c42dbdbbe118e526ecadecf2cf22b.tar.gz
gentoo-03c4e92a7e4c42dbdbbe118e526ecadecf2cf22b.tar.xz
dev-php/pecl-gnupg: Revbump to include php7-1 and php7-2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild')
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild
new file mode 100644
index 00000000000..ab2811be502
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+S="${PHP_EXT_S}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme <app-crypt/gnupg-2"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/1.3.2/01-large_file_system.patch )