summaryrefslogtreecommitdiff
path: root/dev-php/pecl-haru
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-haru
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/Manifest1
-rw-r--r--dev-php/pecl-haru/metadata.xml9
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild28
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/Manifest b/dev-php/pecl-haru/Manifest
new file mode 100644
index 00000000000..d2097ff4b56
--- /dev/null
+++ b/dev-php/pecl-haru/Manifest
@@ -0,0 +1 @@
+DIST haru-1.0.4.tgz 27538 SHA256 ab35e25521b486cc35a645727acd59dabfa0a7c85432f863ddad9e3d01a2ac70 SHA512 75cb8ae200cd41372ac738f5a4ed57607e13d538e2c9a46236dc05b7d0283ed4d152478e12fdff81735a4acd914055ebd58ff937ea0ca0a80056f255217b04c0 WHIRLPOOL a7c930847f2ff71abd9068896b650273f38bfb14d9e9a3f0a8724f43d52db669a27d7290398e70a68d146b18b3b664047f8cec40620ae1f202ef435df522a603
diff --git a/dev-php/pecl-haru/metadata.xml b/dev-php/pecl-haru/metadata.xml
new file mode 100644
index 00000000000..0c93320ef0b
--- /dev/null
+++ b/dev-php/pecl-haru/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">These functions allow you to create PDF documents
+ using the Haru Free PDF Library.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild
new file mode 100644
index 00000000000..75c98ab8773
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf=""
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild
new file mode 100644
index 00000000000..27ca70df08d
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_PHP="php5-4 php5-5"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf=""
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}