summaryrefslogtreecommitdiff
path: root/dev-php/pecl-http
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-08-23 16:14:14 -0400
committerBrian Evans <grknight@gentoo.org>2016-08-23 16:57:51 -0400
commit083c9b7fefedfa14e1fbde7d13b8a79aea3516e9 (patch)
treeb8c5838aa896c8d124a77986b1b232ea714086bd /dev-php/pecl-http
parent7ac0203c113cd880e7a6bc249206e9b006860f95 (diff)
downloadgentoo-083c9b7fefedfa14e1fbde7d13b8a79aea3516e9.tar.gz
gentoo-083c9b7fefedfa14e1fbde7d13b8a79aea3516e9.tar.xz
dev-php/pecl-http: Fix EAPI6 build error when php7-0 is off
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/pecl-http-3.0.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-php/pecl-http/pecl-http-3.0.1.ebuild b/dev-php/pecl-http/pecl-http-3.0.1.ebuild
index 309a14ee49f..1cb5bfc9fd0 100644
--- a/dev-php/pecl-http/pecl-http-3.0.1.ebuild
+++ b/dev-php/pecl-http/pecl-http-3.0.1.ebuild
@@ -35,6 +35,14 @@ RDEPEND="${DEPEND}
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+src_prepare() {
+ if use php_targets_php7-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
pkg_postinst() {
ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
ewarn "Please review the documentation and update your code."