summaryrefslogtreecommitdiff
path: root/dev-php/pecl-radius
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-radius
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-radius')
-rw-r--r--dev-php/pecl-radius/Manifest1
-rw-r--r--dev-php/pecl-radius/files/radius_long.patch15
-rw-r--r--dev-php/pecl-radius/metadata.xml5
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.2.7.ebuild20
4 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-radius/Manifest b/dev-php/pecl-radius/Manifest
new file mode 100644
index 00000000000..fb7f8386043
--- /dev/null
+++ b/dev-php/pecl-radius/Manifest
@@ -0,0 +1 @@
+DIST radius-1.2.7.tgz 35779 SHA256 c4b229b4ee016c13bad326f4eb6b9f3698daed3c559a2d9e7fe05b459334bb34 SHA512 76d8fe4722a25b912e5fcfb3df79027384ce5037c6abec038abdb398698345463bdd17163294dd2734e440a6350380a27d2d2eba525bfc7285b953f726ac4ed5 WHIRLPOOL a8c6b58a166c1763bd5335ef79dfefdec270b6440646f9311200bd375f03fda6693792bdd39504247df16fff05e263fdc1f6e3cca9520a46f820ffd589691a11
diff --git a/dev-php/pecl-radius/files/radius_long.patch b/dev-php/pecl-radius/files/radius_long.patch
new file mode 100644
index 00000000000..090674c4f18
--- /dev/null
+++ b/dev-php/pecl-radius/files/radius_long.patch
@@ -0,0 +1,15 @@
+Gentoo bug: 460836
+Upstream bug: 60885
+
+diff -u php-radius-1.2.5/radius-1.2.5/radius.c php-radius-1.2.5/radius-1.2.5/radius.c
+--- php-radius-1.2.5/radius-1.2.5/radius.c
++++ php-radius-1.2.5/radius-1.2.5/radius.c
+@@ -265,7 +265,7 @@
+ /* {{{ proto bool radius_create_request(desc, code) */
+ PHP_FUNCTION(radius_create_request)
+ {
+- int code;
++ long code;
+ radius_descriptor *raddesc;
+ zval *z_radh;
+
diff --git a/dev-php/pecl-radius/metadata.xml b/dev-php/pecl-radius/metadata.xml
new file mode 100644
index 00000000000..fd3dbe39fa6
--- /dev/null
+++ b/dev-php/pecl-radius/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-radius/pecl-radius-1.2.7.ebuild b/dev-php/pecl-radius/pecl-radius-1.2.7.ebuild
new file mode 100644
index 00000000000..f0ea5fa46b2
--- /dev/null
+++ b/dev-php/pecl-radius/pecl-radius-1.2.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides full support for RADIUS authentication (RFC 2865) and RADIUS accounting (RFC 2866)"
+LICENSE="BSD BSD-2"
+SLOT="0"
+IUSE="examples"