summaryrefslogtreecommitdiff
path: root/dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-25 12:15:08 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-09-25 12:22:23 -0400
commit54d0606ff16ed8b0fd9c596dae8bf867dc40a4b5 (patch)
tree9a17f845774fd2fd191e14c7613b116a5c4c7f2b /dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild
parentab39e5c2ed121b11ce22876f481fd8ee91532d4a (diff)
downloadgentoo-54d0606ff16ed8b0fd9c596dae8bf867dc40a4b5.tar.gz
gentoo-54d0606ff16ed8b0fd9c596dae8bf867dc40a4b5.tar.xz
dev-php/pecl-stomp: version bump fixing DOCS and adding USE=examples.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild b/dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild
new file mode 100644
index 00000000000..72cae633c20
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_PHP="php5-4 php5-5 php5-6"
+PHP_EXT_NAME="stomp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS doc/classes.php doc/functions.php"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp compliant Message Brokers"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="examples +ssl"
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[ssl?] )"
+done
+
+DEPEND="${DEPEND}
+ ${PHPUSEDEPEND}
+"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ my_conf="--enable-stomp
+ $(use_with ssl openssl-dir=/usr)"
+ php-ext-pecl-r2_src_compile
+}