summaryrefslogtreecommitdiff
path: root/dev-php/pecl-yaml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-yaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-yaml')
-rw-r--r--dev-php/pecl-yaml/Manifest1
-rw-r--r--dev-php/pecl-yaml/metadata.xml10
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-1.1.1-r1.ebuild25
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-1.1.1.ebuild25
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/pecl-yaml/Manifest b/dev-php/pecl-yaml/Manifest
new file mode 100644
index 00000000000..9747ea58268
--- /dev/null
+++ b/dev-php/pecl-yaml/Manifest
@@ -0,0 +1 @@
+DIST yaml-1.1.1.tgz 37862 SHA256 762ec3d9eb163ac0d063118df8c5e2ee6746dbe8566d32055e7e066e590937c3 SHA512 cb00ba7bbccc99e0e70ad439e1d0bb11e24a623d00d864f559476d17ff0a6c24e4f6faaffd9da7ecf9a07eaac9cd88609491543546e81ed69b73cfe55536328e WHIRLPOOL 35406331f50b07a18d383e6d114e88c891cfa5a60f963b5a9b2f18d56000acdca07e92d4ddcc2f6deff69346ec3db5ae811c31003cc497cc26d0e991524c4a72
diff --git a/dev-php/pecl-yaml/metadata.xml b/dev-php/pecl-yaml/metadata.xml
new file mode 100644
index 00000000000..09e07c16b25
--- /dev/null
+++ b/dev-php/pecl-yaml/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>olemarkus@gentoo.org</email>
+ <name>Ole Markus With</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-yaml/pecl-yaml-1.1.1-r1.ebuild b/dev-php/pecl-yaml/pecl-yaml-1.1.1-r1.ebuild
new file mode 100644
index 00000000000..58816b86adf
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-1.1.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Support for YAML 1.1 (YAML Ain't Markup Language) serialization
+using the LibYAML library."
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-yaml/pecl-yaml-1.1.1.ebuild b/dev-php/pecl-yaml/pecl-yaml-1.1.1.ebuild
new file mode 100644
index 00000000000..ad504ece2e0
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-1.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL README"
+
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Support for YAML 1.1 (YAML Ain't Markup Language) serialization
+using the LibYAML library."
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND}"