summaryrefslogtreecommitdiff
path: root/dev-php/php-openid
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/php-openid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/php-openid')
-rw-r--r--dev-php/php-openid/Manifest1
-rw-r--r--dev-php/php-openid/metadata.xml8
-rw-r--r--dev-php/php-openid/php-openid-2.2.3_pre20140423.ebuild36
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/php-openid/Manifest b/dev-php/php-openid/Manifest
new file mode 100644
index 00000000000..73a6cc80547
--- /dev/null
+++ b/dev-php/php-openid/Manifest
@@ -0,0 +1 @@
+DIST php-openid-fff9217fb1acda132702730b66b10981ea9d4cac.tar.gz 396390 SHA256 efeac8eaf8880f93d8fcc118e498b944e50a3d23536d5f3c6a7bb16cdfc0634f SHA512 930567426a5aa7d5967f4ef231f78c5719e174e6be7b78f62ecdd9e2bc2ec99e7c6051585ae3a92c6e005e05460d394d81b4c0cdb80ac0ffdfe5eaf6fdb9f625 WHIRLPOOL 6777d7cec562ebb8a4519e4ff451bfd0a8b54d6b881fe119d15de905c9db876e2c431815077d772cefeccc33f36be9d5c426f921c8bba63afd3bb29b0cfe0cb2
diff --git a/dev-php/php-openid/metadata.xml b/dev-php/php-openid/metadata.xml
new file mode 100644
index 00000000000..25958af0e3a
--- /dev/null
+++ b/dev-php/php-openid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="github">openid/php-openid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/php-openid/php-openid-2.2.3_pre20140423.ebuild b/dev-php/php-openid/php-openid-2.2.3_pre20140423.ebuild
new file mode 100644
index 00000000000..d1a841cb8d1
--- /dev/null
+++ b/dev-php/php-openid/php-openid-2.2.3_pre20140423.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PV="fff9217fb1acda132702730b66b10981ea9d4cac"
+MY_P="${PN}-${MY_PV}"
+
+PHP_LIB_NAME="Auth"
+DESCRIPTION="PHP OpenID implementation"
+HOMEPAGE="https://github.com/openid/php-openid"
+SRC_URI="https://github.com/openid/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( dev-lang/php[gmp] dev-lang/php[bcmath] )
+ dev-lang/php[curl,xml,ssl]
+ net-misc/curl[ssl]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ cd "${S}/Auth" && doins -r .
+
+ use examples && dodoc -r ../examples
+}
+
+pkg_postinst() {
+ elog "This ebuild can optionally make use of:"
+ elog " dev-php/PEAR-DB"
+}