summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-30 09:13:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-30 09:13:01 -0500
commitdbee6a9448937a497c7b4455b673acb3ed98dd1c (patch)
treef42034d8939fb06060ebb977fbebe7077d335e1d /dev-python/Babel
parent45cba86466993a043dd4ecece16ff64845f0bd81 (diff)
downloadgentoo-dbee6a9448937a497c7b4455b673acb3ed98dd1c.tar.gz
gentoo-dbee6a9448937a497c7b4455b673acb3ed98dd1c.tar.xz
Revert "dev-python/Babel: Drop old"
This reverts commit 88be89a78b0337603d7d61753d5bbf14024df558.
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.0.ebuild49
-rw-r--r--dev-python/Babel/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.0.ebuild b/dev-python/Babel/Babel-2.0.ebuild
new file mode 100644
index 00000000000..8d461058ab4
--- /dev/null
+++ b/dev-python/Babel/Babel-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ export BUILD_DIR
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index a8b5131969c..578cf1b1b8c 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1 +1,2 @@
+DIST Babel-2.0.tar.gz 3415906 SHA256 44988df191123065af9857eca68e9151526a931c12659ca29904e4f11de7ec1b SHA512 9f12573d97f688baf0d1fc0f61055e34b67964054e70c8a6c286a8b0e42ce58da4d9c8cf54f94e51b47a5256cc4504a14bea497bd626cfad8c860d952e7a5e18 WHIRLPOOL e08b0d2d6192321f653200b9e4e96d898c12ea8176f7e0fb7c2144d3dfb6c4b6c12b85833b05b1a5e2d9ed8cec3712d09c3b0a1822ca9cc7ea4bf1cb24dac3f3
DIST Babel-2.1.1.tar.gz 3437647 SHA256 7fb6d50effe88a087feb2036cb972fd7a893bf338361516f1a55a820bf7b5248 SHA512 ec7ebb8648101588eecc72913adc45c0593ed6ee5f10874edcd4b932959f9552edcecc8e2ec966dae6ef5e8adb23341f1a4f87ea2d9e6cbba57a9b8b0a352a94 WHIRLPOOL 812badf14a74fa391851aaae048ec5d815d6d8f7abce8b918f036243cc45d91ca97281614c2ef139797719077ef4880cfafce88e9d718b3cd633ed7303e4cfd7