summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-04-08 17:28:02 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-04-08 17:40:13 +0200
commita9f058b76a362dbda6b5dbf5332ff8a380188a7b (patch)
tree0afa462638110108afb882877fda132221a0d6c2 /dev-python/PyQt5
parent71e252cc968c193d7d325f37c0d67ff94732a719 (diff)
downloadgentoo-a9f058b76a362dbda6b5dbf5332ff8a380188a7b.tar.gz
gentoo-a9f058b76a362dbda6b5dbf5332ff8a380188a7b.tar.xz
dev-python/PyQt5: remove old
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.5.ebuild179
2 files changed, 0 insertions, 180 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index 08a3ba515d7..12d7478dce2 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1,2 +1 @@
DIST PyQt-gpl-5.5.1.tar.gz 3705749 SHA256 0a70ef94fbffcf674b0dde024aae2a2a7a3f5a8c42806109ff7df2c941bd8386 SHA512 ed9a4f30a50c0879f25b6a0841247f3f0de86942b55c1de9efea963bfbf64ee963a9e5c09be036ff2dec76164863b3b6235e45e8662776425f15378fa0abeab4 WHIRLPOOL 199a36ff1ee3689a76d0aae9d2bee586f9de3a0e3cf23c5b625c1f62b5f19311450afd9d009cbdb4f5be63ba024326c63ff0e6c9ea515216c686db9d8e07bcb3
-DIST PyQt-gpl-5.5.tar.gz 3675521 SHA256 cdd1bb55b431acdb50e9210af135428a13fb32d7b1ab86e972ac7101f6acd814 SHA512 84e591da37032763f961e546250fa1da617e3f9b08c8586e0764d1ecf09fb0eed03b6e602742fa6921a7dd6f10db3255cb834770dba606613bf9897f5276bf43 WHIRLPOOL bcfa7e113ddb692b7d035671f47fcf92300e4ff4048e1c6c44724de0f1b3255d0b4901b88d05cc229263f003c45a6fda4a518127a05484a3cc2b487269c28ca2
diff --git a/dev-python/PyQt5/PyQt5-5.5.ebuild b/dev-python/PyQt5/PyQt5-5.5.ebuild
deleted file mode 100644
index f7a2f64f705..00000000000
--- a/dev-python/PyQt5/PyQt5-5.5.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit eutils multibuild multilib python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="http://www.riverbankcomputing.com/software/pyqt/intro
- https://pypi.python.org/pypi/PyQt5"
-
-MY_PN="PyQt-gpl"
-if [[ ${PV} == *_pre* ]]; then
- MY_P=${MY_PN}-${PV%_pre*}-snapshot-${REVISION}
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
-else
- MY_P=${MY_PN}-${PV}
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ~x86"
-
-# TODO: QtBluetooth, QtLocation, QtNfc, QtWebEngineWidgets
-IUSE="dbus debug declarative designer doc examples gles2 gui help multimedia
- network opengl positioning printsupport sensors serialport sql svg
- testlib webchannel webkit websockets widgets x11extras xmlpatterns"
-
-# The requirements below were extracted from configure.py
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- positioning? ( gui )
- sensors? ( gui )
- serialport? ( gui )
- sql? ( widgets )
- testlib? ( widgets )
- webchannel? ( network )
-"
-
-# Minimal supported version of Qt.
-QT_PV="5.4.2:5"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.16.6:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV}[printsupport] )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Avoid automagic dependency.
- use dbus || rm -fr dbus
-}
-
-pyqt_use_enable() {
- use "$1" || return
-
- if [[ $# -eq 1 ]]; then
- echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
- else
- shift
- echo ${@/#/--enable=}
- fi
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- $(use debug && echo --debug --trace)
- --verbose
- --confirm-license
- --qmake="$(qt5_get_bindir)"/qmake
- --destdir="$(python_get_sitedir)"
- --qsci-api
- --enable=QtCore
- --enable=QtXml
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
- $(usex declarative '' --no-qml-plugin)
- $(pyqt_use_enable designer)
- $(usex designer '' --no-designer-plugin)
- $(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
- $(pyqt_use_enable help)
- $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
- $(pyqt_use_enable network)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable positioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable sensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable sql)
- $(pyqt_use_enable svg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets)
- $(pyqt_use_enable x11extras QtX11Extras)
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- local tmp_root=${D%/}/tmp
- emake INSTALL_ROOT="${tmp_root}" install
-
- local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
-
- python_doexe "${tmp_root}${EPREFIX}"/usr/bin/pyuic5
- rm "${tmp_root}${EPREFIX}"/usr/bin/pyuic5 || die
-
- multibuild_merge_root "${tmp_root}" "${D}"
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- dodoc ChangeLog NEWS
-
- if use doc; then
- dodoc -r doc/html
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}