summaryrefslogtreecommitdiff
path: root/dev-python/adodb-py
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/adodb-py
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/adodb-py')
-rw-r--r--dev-python/adodb-py/Manifest1
-rw-r--r--dev-python/adodb-py/adodb-py-2.20-r1.ebuild36
-rw-r--r--dev-python/adodb-py/files/adodb-py_sandbox_violation.patch22
-rw-r--r--dev-python/adodb-py/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/adodb-py/Manifest b/dev-python/adodb-py/Manifest
new file mode 100644
index 00000000000..8938cade1ce
--- /dev/null
+++ b/dev-python/adodb-py/Manifest
@@ -0,0 +1 @@
+DIST adodb-220.zip 32438 SHA256 92dd475b96853f4932da64c1833cd5247e83cd61196dce67827b4b682d1fa50b SHA512 7aba87a32835b51639240194bc0745d58fd713fe2d6d5d5145f82eb1acb192377bc5dae904fa013b323f38ccd9d8dff77d99c0a8c91e1ee38c21e6a6b05a81d8 WHIRLPOOL d2d3f882c4f10d9a3771b69b40174481a5fed458a3e1d044a4d493b868c5152efdf8e2af67794738979e199a29267e085dbac3b25c954577b7865a38c01d8246
diff --git a/dev-python/adodb-py/adodb-py-2.20-r1.ebuild b/dev-python/adodb-py/adodb-py-2.20-r1.ebuild
new file mode 100644
index 00000000000..7c6847b5f0b
--- /dev/null
+++ b/dev-python/adodb-py/adodb-py-2.20-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite?'
+
+inherit distutils-r1
+
+MY_P=${PN/-py/}-${PV//./}
+
+DESCRIPTION="Active Data Objects Data Base library for Python"
+HOMEPAGE="http://adodb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adodb/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 x86"
+IUSE="mysql postgres sqlite"
+
+RDEPEND="postgres? ( dev-python/psycopg:0[${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/mysql-python-0.9.2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}_sandbox_violation.patch"
+)
+
+python_install_all() {
+ local HTML_DOCS=( adodb-py-docs.htm *.gif )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/adodb-py/files/adodb-py_sandbox_violation.patch b/dev-python/adodb-py/files/adodb-py_sandbox_violation.patch
new file mode 100644
index 00000000000..ca79eb5a7db
--- /dev/null
+++ b/dev-python/adodb-py/files/adodb-py_sandbox_violation.patch
@@ -0,0 +1,22 @@
+diff -uNtr adodb-220.orig/setup.py adodb-220/setup.py
+--- adodb-220.orig/setup.py 2008-07-16 15:28:26.000000000 -0430
++++ adodb-220/setup.py 2009-09-19 00:01:24.000000000 -0430
+@@ -25,17 +25,3 @@
+ except:
+ pass
+
+-
+-for p in sys.path:
+- if p.find('site-packages')>0:
+- trydel(p+os.sep+'adodb.py')
+- trydel(p+os.sep+'adodb_access.py')
+- trydel(p+os.sep+'adodb_mssql.py')
+- trydel(p+os.sep+'adodb_mxodbc.py')
+- trydel(p+os.sep+'adodb_mxoracle.py')
+- trydel(p+os.sep+'adodb_mysql.py')
+- trydel(p+os.sep+'adodb_oci8.py')
+- trydel(p+os.sep+'adodb_odbc.py')
+- trydel(p+os.sep+'adodb_odbc_mssql.py')
+- trydel(p+os.sep+'adodb_postgres.py')
+- trydel(p+os.sep+'adodb_vfp.py')
+\ No newline at end of file
diff --git a/dev-python/adodb-py/metadata.xml b/dev-python/adodb-py/metadata.xml
new file mode 100644
index 00000000000..3f948189258
--- /dev/null
+++ b/dev-python/adodb-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>Database abstraction library for Python</longdescription>
+ <longdescription lang="ja">
+Python言語用データベース抽象化ライブラリです。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">adodb</remote-id>
+ </upstream>
+</pkgmetadata>