summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp/aiohttp-2.3.2.ebuild
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-14 22:04:36 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-14 22:32:02 -0500
commit28131e8594fd0959580baf6b81691423f5bc21e4 (patch)
treeb2f5bbe207e857ab26ff1aa6973eb84377e079c1 /dev-python/aiohttp/aiohttp-2.3.2.ebuild
parent28c94225771fe5c2e2fba6a32703b6ec5253e9fd (diff)
downloadgentoo-28131e8594fd0959580baf6b81691423f5bc21e4.tar.gz
gentoo-28131e8594fd0959580baf6b81691423f5bc21e4.tar.xz
dev-python/aiohttp: version bump to 2.3.2
Diffstat (limited to 'dev-python/aiohttp/aiohttp-2.3.2.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-2.3.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/aiohttp/aiohttp-2.3.2.ebuild b/dev-python/aiohttp/aiohttp-2.3.2.ebuild
new file mode 100644
index 00000000000..669641f6390
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-2.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/async_timeout-1.2.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-0.11[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}