summaryrefslogtreecommitdiff
path: root/dev-python/apptools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/apptools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/apptools')
-rw-r--r--dev-python/apptools/Manifest2
-rw-r--r--dev-python/apptools/apptools-4.2.0-r1.ebuild51
-rw-r--r--dev-python/apptools/apptools-4.2.1.ebuild48
-rw-r--r--dev-python/apptools/files/apptools_test.patch15
-rw-r--r--dev-python/apptools/metadata.xml11
5 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/apptools/Manifest b/dev-python/apptools/Manifest
new file mode 100644
index 00000000000..7916eeb348c
--- /dev/null
+++ b/dev-python/apptools/Manifest
@@ -0,0 +1,2 @@
+DIST apptools-4.2.0.tar.gz 275495 SHA256 0ff03b47529718b6c12de1d5512a7baed9b1be7f5d54f60b953b9235f412d0d4 SHA512 40113a0cc2eedc48ff4d5f7cf685486b397fe19ff57dfd11a66fa77191a7efacbe92373cb93b5ce0748d42a7452724bcf20bd855a36152530d65f178226c6f6e WHIRLPOOL 38807b3998d29292a22c996d902df9695184f26a59b2bbbe899406065beae56183c52cd7ea45ff4003e3f4919baba39733a3fabfae46cd96412ea50895d21bc4
+DIST apptools-4.2.1.tar.gz 274521 SHA256 66f4d61e4be80fd0b153f4a8c1d680c45d5b2e0734899695cb6e918f3f594369 SHA512 03f89b431db496082ac404456f97792f68b580ee77451e6f003b5a2830cd2f698124487045b6cd5fc15b700fbf7467553a384d6e638a322627f8dad7c0b45fc6 WHIRLPOOL 0b0d99b11e251be730b9e5772cce8cfdd0c654fb02ab031fe122f82f8e4555223142e65186c9f3c0068d9b4266f71d6c3209072c3b6939b67daa5ddbc14c3ede
diff --git a/dev-python/apptools/apptools-4.2.0-r1.ebuild b/dev-python/apptools/apptools-4.2.0-r1.ebuild
new file mode 100644
index 00000000000..41c195eea95
--- /dev/null
+++ b/dev-python/apptools/apptools-4.2.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Application tools"
+HOMEPAGE="http://code.enthought.com/projects/app_tools/ http://pypi.python.org/pypi/apptools"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pyface-4[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ sci-visualization/mayavi[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}_test.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r docs/build/html/
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/apptools/apptools-4.2.1.ebuild b/dev-python/apptools/apptools-4.2.1.ebuild
new file mode 100644
index 00000000000..a850c9aa770
--- /dev/null
+++ b/dev-python/apptools/apptools-4.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Application tools"
+HOMEPAGE="http://code.enthought.com/projects/app_tools/ http://pypi.python.org/pypi/apptools"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pyface-4[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Ignore test file that imports a long deprecated module of traits
+ VIRTUALX_COMMAND="nosetests -I test_state_pickler.py" virtualmake
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/apptools/files/apptools_test.patch b/dev-python/apptools/files/apptools_test.patch
new file mode 100644
index 00000000000..ce2d688346b
--- /dev/null
+++ b/dev-python/apptools/files/apptools_test.patch
@@ -0,0 +1,15 @@
+Disable test that use package installed in ${ROOT}
+
+https://bugs.gentoo.org/show_bug.cgi?id=429668
+
+Patch written by Ian Delaney <johneed@hotmail.com>
+--- apptools/persistence/tests/check_version_registry.py
++++ apptools/persistence/tests/check_version_registry.py
+@@ -39,6 +39,7 @@
+
+
+ class TestVersionRegistry(unittest.TestCase):
++ @unittest.skip("This tests uses installed version")
+ def test_get_version(self):
+ """Test the get_version function."""
+ c = Classic()
diff --git a/dev-python/apptools/metadata.xml b/dev-python/apptools/metadata.xml
new file mode 100644
index 00000000000..87c3bbcbfda
--- /dev/null
+++ b/dev-python/apptools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The Enthought Tool Suite AppTools project includes a set of
+ packages that Enthought has found useful in creating a number of
+ applications. They implement functionality that is commonly needed
+ by many applications.
+ </longdescription>
+</pkgmetadata>