summaryrefslogtreecommitdiff
path: root/dev-python/astropy-helpers/astropy-helpers-1.2.ebuild
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-08-31 20:41:30 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-08-31 20:42:03 +0000
commit932088e23e6ac9fbab0d1c0e32af8743394c7963 (patch)
treea4bd66cdae1fb8e2d5f4b1961caaf0a3048252fc /dev-python/astropy-helpers/astropy-helpers-1.2.ebuild
parent27003093937c3e0162477bbd3fd23c5de986d17a (diff)
downloadgentoo-932088e23e6ac9fbab0d1c0e32af8743394c7963.tar.gz
gentoo-932088e23e6ac9fbab0d1c0e32af8743394c7963.tar.xz
dev-python/astropy-helpers: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/astropy-helpers/astropy-helpers-1.2.ebuild')
-rw-r--r--dev-python/astropy-helpers/astropy-helpers-1.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/astropy-helpers/astropy-helpers-1.2.ebuild b/dev-python/astropy-helpers/astropy-helpers-1.2.ebuild
new file mode 100644
index 00000000000..f7cda012b24
--- /dev/null
+++ b/dev-python/astropy-helpers/astropy-helpers-1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers for Astropy and Affiliated packages"
+HOMEPAGE="https://github.com/astropy/astropy-helpers"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+python_prepare_all() {
+ sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
+ distutils-r1_python_prepare_all
+}