summaryrefslogtreecommitdiff
path: root/dev-python/astropy
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 19:55:34 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 19:56:03 +0000
commit4bf936bd6670845bcc0f6cc1f5828dbba9d31f69 (patch)
tree26a4a85c90a744873eed4b8d52aab09e22b11105 /dev-python/astropy
parentb9942a63387834c03c798d4f1ab9ae167f7635a4 (diff)
downloadgentoo-4bf936bd6670845bcc0f6cc1f5828dbba9d31f69.tar.gz
gentoo-4bf936bd6670845bcc0f6cc1f5828dbba9d31f69.tar.xz
dev-python/astropy: fixed for doc generation
Missed dependencies and astropy-helpers local Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604034 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/astropy-1.3.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/astropy/astropy-1.3.ebuild b/dev-python/astropy/astropy-1.3.ebuild
index d85184f42f3..8a49c8cee75 100644
--- a/dev-python/astropy/astropy-1.3.ebuild
+++ b/dev-python/astropy/astropy-1.3.ebuild
@@ -36,9 +36,11 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
dev-libs/libxml2[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/jplephem[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-gallery[${PYTHON_USEDEP}]
dev-python/wcsaxes[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
)
@@ -60,7 +62,7 @@ PATCHES=(
python_prepare_all() {
export mydistutilsargs="--offline"
export ASTROPY_USE_SYSTEM_PYTEST=True
- rm -r ${PN}_helpers || die
+ #rm -r ${PN}_helpers || die
cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
sed -i -e '/auto_use/s/True/False/' setup.cfg || die
@@ -74,10 +76,13 @@ python_prepare_all() {
python_compile_all() {
if use doc; then
+ mkdir -p examples
+ touch examples/README.txt || die
+ python_setup
VARTEXFONTS="${T}"/fonts \
MPLCONFIGDIR="${BUILD_DIR}" \
PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
+ esetup.py build_docs --no-intersphinx
fi
}