summaryrefslogtreecommitdiff
path: root/dev-python/atpy
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/atpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/atpy')
-rw-r--r--dev-python/atpy/Manifest1
-rw-r--r--dev-python/atpy/atpy-0.9.7.ebuild35
-rw-r--r--dev-python/atpy/metadata.xml19
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/atpy/Manifest b/dev-python/atpy/Manifest
new file mode 100644
index 00000000000..0f3e6904789
--- /dev/null
+++ b/dev-python/atpy/Manifest
@@ -0,0 +1 @@
+DIST ATpy-0.9.7.tar.gz 663163 SHA256 4286bb0e4de30df16d6ffd14eb92e4bd47cba2b486834ca95db512c830d0693c SHA512 4cd078625fd4fc83d267cf3aff4728ec8b2de927dd0a748dba47030216b141aa0c266f34bbf708211ec829a363b3b8e5eed36bf538efbe170ae316a271b36bb4 WHIRLPOOL 6e86375725c203b5351c0111a5e10fa6905c9add682b26275f2538e97e3e1b16884c40794809b0b02a0e4f64bd1f3f5d56f474ef5efc5bbd8622dcd639360ecc
diff --git a/dev-python/atpy/atpy-0.9.7.ebuild b/dev-python/atpy/atpy-0.9.7.ebuild
new file mode 100644
index 00000000000..9c9373c483f
--- /dev/null
+++ b/dev-python/atpy/atpy-0.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MYPN=ATpy
+MYP="${MYPN}-${PV}"
+
+DESCRIPTION="Astronomical tables support for Python"
+HOMEPAGE="http://atpy.readthedocs.org/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/astropy[${PYTHON_USEDEP}]
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/pygresql )"
+
+IUSE="hdf5 mysql postgres sqlite"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" "${EPYTHON}" runtests.py || die
+}
diff --git a/dev-python/atpy/metadata.xml b/dev-python/atpy/metadata.xml
new file mode 100644
index 00000000000..a370aeb0557
--- /dev/null
+++ b/dev-python/atpy/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Astronomical Tables in Python (ATpy) is a high-level package
+ providing a way to manipulate tables of astronomical data in a
+ uniform way. A table is defined by any number of columns of data,
+ each characterized by a column name, unit, null value, and
+ description (the last three being optional), and can be supplemented
+ with metadata in the form of keywords or comments. ATpy can be used
+ to manipulate single tables as well as sets of tables. Table formats
+ supported are FITS, VO, IPAC. Database supported are SQLite, MySQL
+ and PostgreSQL.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">ATpy</remote-id>
+</upstream>
+</pkgmetadata>