summaryrefslogtreecommitdiff
path: root/dev-python/awscli/awscli-1.10.51.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-31 18:04:28 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-31 20:12:51 +0200
commit74e42f0de4b8d33076722b03462e0d6dbe384b42 (patch)
treee9634b540984d7bc5183fa32396f13cba168d072 /dev-python/awscli/awscli-1.10.51.ebuild
parent84c9b38cc402612de6fe66b02b289cd47c8f8ee5 (diff)
downloadgentoo-74e42f0de4b8d33076722b03462e0d6dbe384b42.tar.gz
gentoo-74e42f0de4b8d33076722b03462e0d6dbe384b42.tar.xz
dev-python/awscli: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/awscli/awscli-1.10.51.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.10.51.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/awscli/awscli-1.10.51.ebuild b/dev-python/awscli/awscli-1.10.51.ebuild
new file mode 100644
index 00000000000..f1631b5ae3c
--- /dev/null
+++ b/dev-python/awscli/awscli-1.10.51.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="http://pypi.python.org/pypi/awscli"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+ <=dev-python/colorama-0.3.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <=dev-python/rsa-3.5.0[${PYTHON_USEDEP}]
+ dev-python/s3transfer[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "