summaryrefslogtreecommitdiff
path: root/dev-python/blinker
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-09 15:56:04 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-09 16:10:02 +0100
commitdd2a2c8b547eb3aa14b25ae853adcf34c49c2ac4 (patch)
tree9d394c2a6fa6edfb7e91e15ec5296623c64d0678 /dev-python/blinker
parentb3e759e905b577811c189409f33d8eaa31394d22 (diff)
downloadgentoo-dd2a2c8b547eb3aa14b25ae853adcf34c49c2ac4.tar.gz
gentoo-dd2a2c8b547eb3aa14b25ae853adcf34c49c2ac4.tar.xz
dev-python/blinker: Add python3.5 support
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/blinker')
-rw-r--r--dev-python/blinker/blinker-1.4.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/blinker/blinker-1.4.ebuild b/dev-python/blinker/blinker-1.4.ebuild
index 8dd8c8d0364..72c4bc693fa 100644
--- a/dev-python/blinker/blinker-1.4.ebuild
+++ b/dev-python/blinker/blinker-1.4.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
@@ -19,15 +20,10 @@ IUSE="doc test"
DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
+ nosetests -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
+ HTML_DOCS=( docs/html/. )
distutils-r1_python_install_all
- if use doc; then
- pushd docs/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static
- popd > /dev/null
- fi
}