summaryrefslogtreecommitdiff
path: root/dev-python/bokeh
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-09 19:27:03 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-09 19:27:03 +0100
commit5e24ecf7bbd75e54fc34939c9daa7fe1cb033809 (patch)
treefa958fad582804a37c583494e5557fd470519b09 /dev-python/bokeh
parentdcc39193280a02b411308cdd084907409d4ac936 (diff)
downloadgentoo-5e24ecf7bbd75e54fc34939c9daa7fe1cb033809.tar.gz
gentoo-5e24ecf7bbd75e54fc34939c9daa7fe1cb033809.tar.xz
Revert "dev-python/bokeh: Drop old"
This reverts commit 20c37df5f09964b6949917de65e6a785c8a791d7.
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/Manifest1
-rw-r--r--dev-python/bokeh/bokeh-0.7.1.ebuild90
-rw-r--r--dev-python/bokeh/files/bokeh-0.7.1-setup.patch17
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
index e2fda9e529d..43003de3336 100644
--- a/dev-python/bokeh/Manifest
+++ b/dev-python/bokeh/Manifest
@@ -1 +1,2 @@
DIST bokeh-0.10.0.tar.gz 4474129 SHA256 2d8bd8c98e2f62b2a28328d3cc95bfbe257742fa7efc9c382b4c8ae4a141df14 SHA512 19023f1e67245005581b8640380045a8795747da75025478881f9d3791e82289ee75b74142b38a0bae9c236c0b1b6df1629376d5c3fcc319ceafb0a4abc7240f WHIRLPOOL 86e8e3774287164d2d7da0a04ceddb62eb03a19e48c82acf806c1a356d361f655bd6087f15b740ab36b84891ed849435e2a9c6098e881f07299cce8553d88fb2
+DIST bokeh-0.7.1.tar.gz 30039486 SHA256 167125e07df2ea1f65b1b6dfed140b7b6ed7452a1182ad4cb0be2580af537f73 SHA512 cf2ee6457cab7ca0a98c2cf19a7814e081245b30cf6f4f4670f8fc60b216bb39f14d3cdf52c92f85635cbf6419db00c0c01adb2e1a6eeaa019cdc767c642c160 WHIRLPOOL 23e66370f1cab2d3a3c40b0713e5cdb50afa7aeec1c2d1172a1d9a5598c004dd351509973ac84f24ebb30dbc5a86de455e1dfcbe00daf6a1d12c3e336122a2b8
diff --git a/dev-python/bokeh/bokeh-0.7.1.ebuild b/dev-python/bokeh/bokeh-0.7.1.ebuild
new file mode 100644
index 00000000000..048fbe2ede2
--- /dev/null
+++ b/dev-python/bokeh/bokeh-0.7.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Statistical and interactive HTML plots for Python"
+HOMEPAGE="http://bokeh.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+# A doc build requires napoleon sphinx extension which will be included in sphinx release 1.3
+# Therefore refraining from adding the doc build for now
+RDEPEND="
+ >=dev-python/colorama-0.2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-0.18[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pystache-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013b[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-2.7.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.9.1[${PYTHON_USEDEP}]
+ >=net-libs/nodejs-0.8.28[npm]
+ >=www-client/phantomjs-1.9.8
+ >=www-servers/tornado-4.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/gevent-1.0[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/gevent-websocket-0.9.2[${PYTHON_USEDEP}]' python2_7)
+ "
+# testing server: needs websocket not in portage yet
+# websocket is in pypi for the adding
+# hdf5 backend: needs array management not in portage yet
+DEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/colorama-0.2.7[${PYTHON_USEDEP}] )
+ "
+DOCS=( CHANGELOG QUICKSTART.md README.md )
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_prepare_all() {
+ DOC_CONTENTS="websockets work only with python2_7"
+
+ sed -i -e "s/jsbuild = get_user_jsargs()/jsbuild = False/g" setup.py || die
+ cd bokehjs || die
+ npm install ||die
+ cd .. || die
+ esetup.py --build_js sdist
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ readme.gentoo_create_doc
+
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # exclude server tests for now
+ nosetests -v \
+ -e multiuser_auth_test \
+ -e usermodel_test \
+ || die
+}
diff --git a/dev-python/bokeh/files/bokeh-0.7.1-setup.patch b/dev-python/bokeh/files/bokeh-0.7.1-setup.patch
new file mode 100644
index 00000000000..39ea156cc3b
--- /dev/null
+++ b/dev-python/bokeh/files/bokeh-0.7.1-setup.patch
@@ -0,0 +1,17 @@
+Remove inappropriate check for a previous installation.
+
+Original patch for bokek 0.5.0 (0.5.0-setup.patch).
+Ported for bokeh 0.7.1 by Marius Brehler.
+
+http://bugs.gentoo.org/527336
+
+--- setup.py
++++ setup.py.new
+@@ -348,7 +348,6 @@ path = abspath(dirname(__file__))
+
+ print()
+ if 'develop' in sys.argv:
+- check_remove_bokeh_install(site_packages)
+ with open(path_file, "w+") as f:
+ f.write(path)
+ print("Installing Bokeh for development:")