summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-4.0.0.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-25 09:53:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-25 09:57:51 +0200
commit3437bbd03af38ded0bf3148e565116176e63e38c (patch)
tree852119da1cf3ea25565e195984650c946914d8b2 /dev-python/clang-python/clang-python-4.0.0.ebuild
parent88186e51dac2792008ba3c5cdcc60b5cfd567405 (diff)
downloadgentoo-3437bbd03af38ded0bf3148e565116176e63e38c.tar.gz
gentoo-3437bbd03af38ded0bf3148e565116176e63e38c.tar.xz
dev-python/clang-python: Clean old up
Diffstat (limited to 'dev-python/clang-python/clang-python-4.0.0.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-4.0.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/clang-python/clang-python-4.0.0.ebuild b/dev-python/clang-python/clang-python-4.0.0.ebuild
deleted file mode 100644
index c77ee951ec2..00000000000
--- a/dev-python/clang-python/clang-python-4.0.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit python-r1
-
-DESCRIPTION="Python bindings for sys-devel/clang"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/cfe-${PV/_/}.src.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# The module is opening libclang.so directly, and doing some blasphemy
-# on top of it.
-RDEPEND="
- >=sys-devel/clang-${PV}:*
- !sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
-
-src_test() {
- python_foreach_impl nosetests -v || die
-}
-
-src_install() {
- python_foreach_impl python_domodule clang
-}