summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-4.0.0_rc2.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-14 21:45:16 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-15 13:47:30 +0100
commit25c536991ff7f8bf7218be8f94ea09c259eb5fd6 (patch)
tree863db85e54f38520f09820c668f7b835e7021210 /dev-python/clang-python/clang-python-4.0.0_rc2.ebuild
parent89f02e8736af383b076c9e57c1d8665da3580fff (diff)
downloadgentoo-25c536991ff7f8bf7218be8f94ea09c259eb5fd6.tar.gz
gentoo-25c536991ff7f8bf7218be8f94ea09c259eb5fd6.tar.xz
dev-python/clang-python: Bump to 4.0.0.rc2
Diffstat (limited to 'dev-python/clang-python/clang-python-4.0.0_rc2.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-4.0.0_rc2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-4.0.0_rc2.ebuild b/dev-python/clang-python/clang-python-4.0.0_rc2.ebuild
new file mode 100644
index 00000000000..0b0cc4428fa
--- /dev/null
+++ b/dev-python/clang-python/clang-python-4.0.0_rc2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://www.llvm.org/pre-releases/${PV/_//}/cfe-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
+
+src_test() {
+ python_foreach_impl nosetests -v
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}