summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-12-27 09:36:27 -0500
committerBrian Evans <grknight@gentoo.org>2017-12-27 09:42:28 -0500
commitccfa90a0710a2e99e5de2ed0ff3a56b73aa8f587 (patch)
tree3c8bdecf7a90108eae4b532074f51104a7636d56 /dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
parent53c1b62350951ce02b7ba824227e1f1e0f7a48af (diff)
downloadgentoo-ccfa90a0710a2e99e5de2ed0ff3a56b73aa8f587.tar.gz
gentoo-ccfa90a0710a2e99e5de2ed0ff3a56b73aa8f587.tar.xz
dev-python/cli_helpers: Version bump to 1.0.1
Closes: https://bugs.gentoo.org/642396 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-1.0.1.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild b/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
new file mode 100644
index 00000000000..34fa368a6ea
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+
+HOMEPAGE="http://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+"