summaryrefslogtreecommitdiff
path: root/dev-python/click/click-6.6.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-17 19:52:19 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-17 23:03:23 +0200
commitb80c6148b3b152f963f3d3cfe619adfb3af0268f (patch)
treea2d4fb5d6515d4caef1da3f0574558d9ca3cd920 /dev-python/click/click-6.6.ebuild
parent0a0b4d02f7f57445f01232c8abe26ffb24cc34c5 (diff)
downloadgentoo-b80c6148b3b152f963f3d3cfe619adfb3af0268f.tar.gz
gentoo-b80c6148b3b152f963f3d3cfe619adfb3af0268f.tar.xz
dev-python/click: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/click/click-6.6.ebuild')
-rw-r--r--dev-python/click/click-6.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/click/click-6.6.ebuild b/dev-python/click/click-6.6.ebuild
new file mode 100644
index 00000000000..6c9a3dcf738
--- /dev/null
+++ b/dev-python/click/click-6.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}