summaryrefslogtreecommitdiff
path: root/dev-python/colander/colander-1.3.1.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-17 20:03:16 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-17 23:03:23 +0200
commit7565a955b59c37db3e401ee3e2374097a64e35ae (patch)
tree3568794c8b7220766028cc3c1e54868f699d1a88 /dev-python/colander/colander-1.3.1.ebuild
parentb47560a8e7d50095820e4b34ce05cf28da44e7d8 (diff)
downloadgentoo-7565a955b59c37db3e401ee3e2374097a64e35ae.tar.gz
gentoo-7565a955b59c37db3e401ee3e2374097a64e35ae.tar.xz
dev-python/colander: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/colander/colander-1.3.1.ebuild')
-rw-r--r--dev-python/colander/colander-1.3.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/colander/colander-1.3.1.ebuild b/dev-python/colander/colander-1.3.1.ebuild
new file mode 100644
index 00000000000..e5d17629cce
--- /dev/null
+++ b/dev-python/colander/colander-1.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple schema-based serialization and deserialization library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ https://pypi.python.org/pypi/colander"
+MY_P=${P/_beta1/b1}
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+# MIT license is used by included (modified) iso8601.py code.
+LICENSE="repoze MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+# Depend on an ebuild of translationstring with Python 3 support.
+RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}] )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.rst COPYRIGHT.txt README.rst )
+
+python_prepare_all() {
+ # Remove pylons theme since it's not included in source
+ sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # https://github.com/Pylons/colander/issues/38
+ emake -C docs html SPHINXOPTS=""
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}