summaryrefslogtreecommitdiff
path: root/dev-python/cycler
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-16 11:19:13 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-16 11:19:20 +0100
commite2b69b9548199d875b3fbac101f5b6dbaf34c031 (patch)
treeed25147c16960a1aaf6265a7250e765448cfb7e4 /dev-python/cycler
parent9c046d0d536f6194b66c11799c83c7feda9de7cb (diff)
downloadgentoo-e2b69b9548199d875b3fbac101f5b6dbaf34c031.tar.gz
gentoo-e2b69b9548199d875b3fbac101f5b6dbaf34c031.tar.xz
dev-python/cycler: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cycler')
-rw-r--r--dev-python/cycler/Manifest1
-rw-r--r--dev-python/cycler/cycler-0.10.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cycler/Manifest b/dev-python/cycler/Manifest
index 6b92f8285f2..1613634b434 100644
--- a/dev-python/cycler/Manifest
+++ b/dev-python/cycler/Manifest
@@ -1 +1,2 @@
+DIST cycler-0.10.0.tar.gz 16553 SHA256 cd7b2d1018258d7247a71425e9f26463dfb444d411c39569972f4ce586b0c9d8 SHA512 b7d2ba19861ffaf4dea0444bfe68b5a6264a022d7b3f02c9ff5e5859e3901de12a90f8dc7469e995e09c418515b3df55dbf05a0cfe5368d40790a2c878a74819 WHIRLPOOL 59c42f5b1d3fcf917cd19d8a9365614f07257d74135d8ee7dc231599bc600d1cf9e0c9a6e822c8aa1a932a31603e2a044b61143d648138e7e549d46a2f1b58f6
DIST cycler-0.9.0.tar.gz 3472 SHA256 96dc4ddf27ef62c09990c6196ac1167685e89168042ec0ae4db586de023355bc SHA512 fc48d432eeeff4eb2f148cc3a07ac6affb422481d4d1405fbcb505442d64929ce1cfcbf4cac7e64ce3192b24991dadee591cd01ae8a6118e45d11d316064e6cb WHIRLPOOL 46cba5b7fe4a634ed1e847df90038da4fdeb0ce55ecc811a6adcb71f999417c862c79ff6499984c8bb6403e84f382984ffed6008fdd1b1807491adccc4d5499e
diff --git a/dev-python/cycler/cycler-0.10.0.ebuild b/dev-python/cycler/cycler-0.10.0.ebuild
new file mode 100644
index 00000000000..0e19cb15e40
--- /dev/null
+++ b/dev-python/cycler/cycler-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+MY_PN="Cycler"
+
+DESCRIPTION="Composable style cycles"
+HOMEPAGE="
+ http://matplotlib.org/cycler/
+ https://pypi.python.org/pypi/Cycler/
+ http://github.com/matplotlib/cycler"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Not shipped
+# https://github.com/matplotlib/cycler/issues/21
+RESTRICT=test
+
+python_test() {
+ nosetests --verbosity=3 || die
+}