summaryrefslogtreecommitdiff
path: root/dev-python/cython
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-10-27 12:31:20 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-10-27 12:31:20 -0500
commit4830721defeb28ef05d8b96665c49ed40684df89 (patch)
treeb0753395a6d59c9bc01de201af9ff05bf738b402 /dev-python/cython
parentfc8fb91046efd9d07f74a496759ff2322d1fd67e (diff)
downloadgentoo-4830721defeb28ef05d8b96665c49ed40684df89.tar.gz
gentoo-4830721defeb28ef05d8b96665c49ed40684df89.tar.xz
dev-python/cython: drop version that introduced new_build_ext by default
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.25.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 33836a4e07b..5a3965d1aea 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,4 +1,3 @@
DIST Cython-0.22.tar.gz 1584483 SHA256 14307e7a69af9a0d0e0024d446af7e51cc0e3e4d0dfb10d36ba837e5e5844015 SHA512 856220fa579e272ac38dcef091760f527431ff3b98df9af6e68416fcf77d9659ac5abe5c7dee41331f359614637a4ff452033085335ee499830ed126ab584267 WHIRLPOOL d9919e1fe33f7ea02833c485e10667d8470d7c69901b2419c6c4c1d464f9ef2444795e14903cc66b6fee40ec5a4c20308c331ad93fd8818f207d0a21cccf9b2b
DIST Cython-0.24.1.tar.gz 1703756 SHA256 84808fda00508757928e1feadcf41c9f78e9a9b7167b6649ab0933b76f75e7b9 SHA512 c5a3e884edd782c47c81aef29708035bbcd1c14d17e005668da8a4e26fdbba9af9ec283fd46ceaa2cab6fc4ec0d42f7d409832d7cc0a3ec00e84b968b1bf27ea WHIRLPOOL 14224a56c5a6f5cd3f389225c440c65b30a5d1b92c63587c4e9af258b23b1bed1c01330830931c5aba596649d19b0aafd0e559aed5ad7b577a59417463fc3b4a
DIST Cython-0.25.1.tar.gz 1701919 SHA256 e0941455769335ec5afb17dee36dc3833b7edc2ae20a8ed5806c58215e4b6669 SHA512 cde26de8b7a626ee39e66223e5b9b3d6b2db182531da7c36f1d63bd720693e710f1976eaeaa4745e7a4b7872ec608ba4784569199303bcbabe1cc464da2ad913 WHIRLPOOL ff5176ab6433767af1f44a16d27d35c8bf12dcf6cadcb37372b118a1613855cfeb9b1786e6449d922df9ad6bef6873e4d818fbb36656eaf532468480b42a76e9
-DIST Cython-0.25.tar.gz 1701330 SHA256 c651eeec6bdcb57de59527e8765c9d2c4970c56bf96731893df66dda17aba46b SHA512 eafe71e4572a23ac1fb2a1461d41257eabe945036ae676f8ac1307262298eaadcd2b252bb7aa9fa061dfb1e076898e52f31fd392b5d7a90f0e766f98f9fa3f78 WHIRLPOOL 6920cb6c8fdc89bdc95a49df8fec4e899684423b92424c20fa7344bbed71130682c0e0656be00f16731f0097e04bab4a4a562bc1ead1e4a5874ae5eae5eb2de5
diff --git a/dev-python/cython/cython-0.25.ebuild b/dev-python/cython/cython-0.25.ebuild
deleted file mode 100644
index 44785313231..00000000000
--- a/dev-python/cython/cython-0.25.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs elisp-common
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://cython.org https://pypi.python.org/pypi/Cython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE="doc emacs test"
-
-RDEPEND="
- emacs? ( virtual/emacs )
-"
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-SITEFILE=50cython-gentoo.el
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use emacs && elisp-compile Tools/cython-mode.el
-
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} Tools/cython-mode.*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}