summaryrefslogtreecommitdiff
path: root/dev-python/datashape/datashape-0.5.3.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-18 11:03:33 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-18 11:32:10 +0200
commit408c4a56b255f6f83d639c2b585b97145e971566 (patch)
tree6f480660ef471e381ecf7109c11933455d0b77b3 /dev-python/datashape/datashape-0.5.3.ebuild
parent475afc3c7069ea06f794b1e99be4740ad4ca6c3e (diff)
downloadgentoo-408c4a56b255f6f83d639c2b585b97145e971566.tar.gz
gentoo-408c4a56b255f6f83d639c2b585b97145e971566.tar.xz
dev-python/datashape: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/datashape/datashape-0.5.3.ebuild')
-rw-r--r--dev-python/datashape/datashape-0.5.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/datashape/datashape-0.5.3.ebuild b/dev-python/datashape/datashape-0.5.3.ebuild
new file mode 100644
index 00000000000..602a6f46c05
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}