summaryrefslogtreecommitdiff
path: root/dev-python/django-nose/django-nose-1.4.2.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-28 11:52:54 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-28 11:52:54 +0100
commitbb2706ed5bb7aa81b42986f6c2755c9c0afa9822 (patch)
tree0af1357a7b51e36a145cd609c8ddb98083a3514b /dev-python/django-nose/django-nose-1.4.2.ebuild
parent8bc9a2ea365c25154004311b1983970cbc21b5f5 (diff)
downloadgentoo-bb2706ed5bb7aa81b42986f6c2755c9c0afa9822.tar.gz
gentoo-bb2706ed5bb7aa81b42986f6c2755c9c0afa9822.tar.xz
dev-python/django-nose: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-nose/django-nose-1.4.2.ebuild')
-rw-r--r--dev-python/django-nose/django-nose-1.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-nose/django-nose-1.4.2.ebuild b/dev-python/django-nose/django-nose-1.4.2.ebuild
new file mode 100644
index 00000000000..e63592d3bc0
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+#RESTRICT="test" # The testsuite currently broken See notes below
+
+RDEPEND="
+ >=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/dj-database-url-0.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ ./runtests.sh --verbose || die
+}