summaryrefslogtreecommitdiff
path: root/dev-python/django-recaptcha
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-recaptcha
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-recaptcha')
-rw-r--r--dev-python/django-recaptcha/Manifest2
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild27
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-1.0.4.ebuild27
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-fields.patch18
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-settings.patch6
-rw-r--r--dev-python/django-recaptcha/files/test_settings.py14
-rw-r--r--dev-python/django-recaptcha/metadata.xml9
7 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/django-recaptcha/Manifest b/dev-python/django-recaptcha/Manifest
new file mode 100644
index 00000000000..32c49fb26f6
--- /dev/null
+++ b/dev-python/django-recaptcha/Manifest
@@ -0,0 +1,2 @@
+DIST django-recaptcha-1.0.3.tar.gz 11268 SHA256 ca47210207e81d8237ff0c5cf51ce07b95ff83dcf5f1e03bb813b6e0cb853af6 SHA512 9288ba1b4145dd6a08f39d226eeaa5f9ea6d9ff63714ff497fe808dfbe249918e4bb67790566044bceeb59ed293a8fcfe4fb41e279b17b2d7a0a0c5a53dd6463 WHIRLPOOL 079349c118a163c6ba6addd18001b1a50a3139c1ff7cd8729e0c77d51f2a798d6aa32e911fcdfc57727eddb5e9bde58639256ba254a759790a0077b6aeb766a5
+DIST django-recaptcha-1.0.4.tar.gz 12036 SHA256 8af0da767b07ca4d7a5a2be329776fe6dbab183c3da61ae30796e1a9354eea6c SHA512 45a149250c2f2ca9d00591027bd9f8264fc2ba90a5f09b4a96484326c0805d86f690bf02255a1a112d5705d357b6db2fdf97ca8f26681692f7c1f07118c9c2e4 WHIRLPOOL 620afa904beb41e09b9e178de08785f915c21170e43c558f66fb6f1fba175839bf9d39eeb7094056f1a4fef7b52d79074436699708932639be7f24419d06718b
diff --git a/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild b/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild
new file mode 100644
index 00000000000..e19a0dbec2a
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/django-setuptest-0.1[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/django-recaptcha/django-recaptcha-1.0.4.ebuild b/dev-python/django-recaptcha/django-recaptcha-1.0.4.ebuild
new file mode 100644
index 00000000000..4917c341d56
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="<dev-python/django-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/django-setuptest-0.1[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-fields.patch b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
new file mode 100644
index 00000000000..2bd0d32c967
--- /dev/null
+++ b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
@@ -0,0 +1,18 @@
+diff -ur django-recaptcha-0.0.6.orig/captcha/fields.py django-recaptcha-0.0.6/captcha/fields.py
+--- captcha/fields.py 2013-01-31 17:05:59.000000000 +0800
++++ captcha/fields.py 2013-03-07 01:44:54.804708648 +0800
+@@ -2,13 +2,12 @@
+ import sys
+
+ from django import forms
+-from django.conf import settings
+ from django.utils.encoding import smart_unicode
+ from django.utils.translation import ugettext_lazy as _
+
+ from captcha import client
+ from captcha.widgets import ReCaptcha
+-
++from captcha import test_settings as settings
+
+ class ReCaptchaField(forms.CharField):
+ default_error_messages = {
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-settings.patch b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
new file mode 100644
index 00000000000..c28694ee4d1
--- /dev/null
+++ b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
@@ -0,0 +1,6 @@
+--- /dev/null 2013-03-05 00:07:00.881999836 +0800
++++ captcha/settings.py 2013-03-07 02:27:52.302580399 +0800
+@@ -0,0 +1,3 @@
++RECAPTCHA_PUBLIC_KEY='76wtgdfsjhsydt7r5FFGFhgsdfytd656sad75fgh'
++RECAPTCHA_PRIVATE_KEY='98dfg6df7g56df6gdfgdfg65JHJH656565GFGFGs'
++RECAPTCHA_USE_SSL='True'
diff --git a/dev-python/django-recaptcha/files/test_settings.py b/dev-python/django-recaptcha/files/test_settings.py
new file mode 100644
index 00000000000..5e66d9e454a
--- /dev/null
+++ b/dev-python/django-recaptcha/files/test_settings.py
@@ -0,0 +1,14 @@
+DATABASES = {
+ 'default': {
+ 'ENGINE': 'django.db.backends.sqlite3',
+ 'NAME': 'test.sqlite',
+ }
+}
+
+INSTALLED_APPS = [
+ 'captcha',
+]
+
+RECAPTCHA_PRIVATE_KEY = '98dfg6df7g56df6gdfgdfg65JHJH656565GFGFGs'
+RECAPTCHA_PUBLIC_KEY = '76wtgdfsjhsydt7r5FFGFhgsdfytd656sad75fgh'
+RECAPTCHA_USE_SSL='True'
diff --git a/dev-python/django-recaptcha/metadata.xml b/dev-python/django-recaptcha/metadata.xml
new file mode 100644
index 00000000000..ea4eb75ba88
--- /dev/null
+++ b/dev-python/django-recaptcha/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-recaptcha</remote-id>
+ <remote-id type="github">preakelt/django-recaptcha</remote-id>
+ </upstream>
+</pkgmetadata>