summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-10 13:41:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-10 13:41:47 -0500
commitc24dccdc70fb97f1716673441d6d7fedfde23472 (patch)
treeddbdbdbd7d9cd20733cba7f78a443810ae523568 /dev-python/dnspython
parent69e67d2d995c176b6bef8f45c47e8d60202f65be (diff)
downloadgentoo-c24dccdc70fb97f1716673441d6d7fedfde23472.tar.gz
gentoo-c24dccdc70fb97f1716673441d6d7fedfde23472.tar.xz
dev-python/dnspython: bump and combine py2/3 into one ebuild bug 596502
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-1.15.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 85f7d4a1a28..ec353dda26f 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1,3 @@
DIST dnspython-1.12.0.tar.gz 135164 SHA256 03fb82af866001c4afa58c48027bcc4b80bbf0a7f27e1d861cf06393eea4724f SHA512 583d069ed7ee9b20f16a964023fa0300f15032c27de6d084205f73394f19a2d5bb1641ef95b08a8ddf1f622eeb5fa8cbfa62b8a2ee478a49b0dff0995e4ae42e WHIRLPOOL abf515aad901b0c752a0f133c293654f60750522cee69985126547602f321f6577e135077cbfa330a30fbc838b125af30b75cbb4f8fdd60d1444b0bd2446bb39
+DIST dnspython-1.15.0.zip 252157 SHA256 40f563e1f7a7b80dc5a4e76ad75c23da53d62f1e15e6e517293b04e1f84ead7c SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1 WHIRLPOOL 83c43d0a53c514d91c096a3f7a761f47583ffb79dde9c233fd063f5b556287671d6012267239c1271696cf2b5e8965525b6612721781749bcdabb484f0dc5d5f
DIST dnspython3-1.12.0.zip 226945 SHA256 e9630946207864c7a780798809cd2ec9c6bbde6ac88b97a2fda66f018eec1c8d SHA512 02c61eb91c2e872f2c8fa0e09b88d593a067130b5ac3ea6eabd0abec413ecb6d3b7d5472ca502334f4c441af249511109006ae6a7b41d36ba1db3e777971b3ae WHIRLPOOL d3624f8545c607441931dcc71a1e43c83df6e1bd938222d52c8d798b342c4faf15f200bf1da7ea1fd59d2fe96e82644b22c8815764bf7d6304573deee6261f5a
diff --git a/dev-python/dnspython/dnspython-1.15.0.ebuild b/dev-python/dnspython/dnspython-1.15.0.ebuild
new file mode 100644
index 00000000000..4f2ef6946f3
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}