summaryrefslogtreecommitdiff
path: root/dev-python/dominate
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-17 02:01:17 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-16 21:17:07 -0400
commit15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb (patch)
treec22387a6c38ed487185be3c3187b7ef62fee5052 /dev-python/dominate
parent5c42ff2ae3698f6be23f0ae753bccca378dc61dc (diff)
downloadgentoo-15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb.tar.gz
gentoo-15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb.tar.xz
dev-python/dominate: bump to 2.2.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest1
-rw-r--r--dev-python/dominate/dominate-2.2.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index 745db7c5f1a..8640fc5b03b 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1 +1,2 @@
DIST dominate-2.2.0.tar.gz 23320 SHA256 318063a9b600cdc13f84592ad515db0fd3a2816a2433e2a2fad55a5398ae05da SHA512 416fa8ac56856aa06d547a307cdf46ca71b3a29caf36103e78a2522973e407cab90c0163a34fd8ed724586a6121bbd8f4822da78dbf1f77c18e9106aab112e74 WHIRLPOOL 9d5e8516d90b947c88c76e39b0ca73ff07737e36dd9336bd70f73fe5f3836d0fc43f28a7c1343e880367a449a117a1fdfa7e48c8b35f502ba20950b328f62c3b
+DIST dominate-2.2.1.zip 46460 SHA256 4aa6a2f458461541f9ceeb58b49da9b42320f80aa2a6f692baea2817431d9953 SHA512 3f79fa4258f98708b1e169693e83f919179c1148f440300426f907e28c26b28c21a1098793a14f7e89e5aba0de61f93c889a4908f0eb6e3641ffe234e215e597 WHIRLPOOL 18b57dfc4d0f825be45a1b248e434a8a013d5b76f065b854c47aab9d99c00f5d1854fbcd3c520de50b11b5d7f079f6e57b2e7167249b7e71ff980ac02dfd8100
diff --git a/dev-python/dominate/dominate-2.2.1.ebuild b/dev-python/dominate/dominate-2.2.1.ebuild
new file mode 100644
index 00000000000..94745def14f
--- /dev/null
+++ b/dev-python/dominate/dominate-2.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}