summaryrefslogtreecommitdiff
path: root/dev-python/enable/files
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:28 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:44 +0200
commite3a0d23f4ad40c56ab64367c541a368ce145c3ae (patch)
treed035629cfa397d6fc32b6ce05913a877b7e1fb16 /dev-python/enable/files
parentbce23afa245ec4b4d1b68e629e48d18168336069 (diff)
downloadgentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.gz
gentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.xz
dev-python/enable: Add support for gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561836 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enable/files')
-rw-r--r--dev-python/enable/files/enable-4.5.1-gcc-5.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/enable/files/enable-4.5.1-gcc-5.patch b/dev-python/enable/files/enable-4.5.1-gcc-5.patch
new file mode 100644
index 00000000000..b18b8eae7bb
--- /dev/null
+++ b/dev-python/enable/files/enable-4.5.1-gcc-5.patch
@@ -0,0 +1,22 @@
+From 55a74ccfc33764499497022dd3649be4bb1091ed Mon Sep 17 00:00:00 2001
+From: Nathan Ringo <tikiking1@users.noreply.github.com>
+Date: Wed, 10 Jun 2015 22:06:57 -0500
+Subject: [PATCH] Fixes #200
+
+---
+ kiva/agg/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kiva/agg/setup.py b/kiva/agg/setup.py
+index 5b4d458..c6e290a 100644
+--- a/kiva/agg/setup.py
++++ b/kiva/agg/setup.py
+@@ -170,7 +170,7 @@ def get_ft2_sources((lib_name, build_info), build_dir):
+ f = os.popen("g++ --version")
+ line0 = f.readline()
+ f.close()
+- m = re.match(r'.+?\s(3|4)\.\d+', line0)
++ m = re.match(r'.+?\s([3-5])\.\d+', line0)
+ if int(m.group(1)) < 4:
+ use_32bit_workaround = True
+